HDU 4451 Dressing(計數)

Dressing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3807    Accepted Submission(s): 1722


Problem Description
Wangpeng has N clothes, M pants and K shoes so theoretically he can have N×M×K different combinations of dressing.
One day he wears his pants Nike, shoes Adiwang to go to school happily. When he opens the door, his mom asks him to come back and switch the dressing. Mom thinks that pants-shoes pair is disharmonious because Adiwang is much better than Nike. After being asked to switch again and again Wangpeng figure out all the pairs mom thinks disharmonious. They can be only clothes-pants pairs or pants-shoes pairs.
Please calculate the number of different combinations of dressing under mom’s restriction.
 

Input
There are multiple test cases.
For each case, the first line contains 3 integers N,M,K(1≤N,M,K≤1000) indicating the number of clothes, pants and shoes.
Second line contains only one integer P(0≤P≤2000000) indicating the number of pairs which mom thinks disharmonious.
Next P lines each line will be one of the two forms“clothes x pants y” or “pants y shoes z”.
The first form indicates pair of x-th clothes and y-th pants is disharmonious(1≤x≤N,1 ≤y≤M), and second form indicates pair of y-th pants and z-th shoes is disharmonious(1≤y≤M,1≤z≤K).
Input ends with “0 0 0”.
It is guaranteed that all the pairs are different.
 

Output
For each case, output the answer in one line.
 

Sample Input
2 2 2 0 2 2 2 1 clothes 1 pants 1 2 2 2 2 clothes 1 pants 1 pants 1 shoes 1 0 0 0
 

Sample Output
8 6 5 題意:衣服褲子鞋子分別有n,m,k件,指定某件衣服跟褲子不能搭配,或者某件褲子跟某雙鞋子不能搭配,這個的指定有P條,問你有幾種不同的搭配方式。 解題思路:用兩個數組 c[maxn] 和 s[maxn] 分別表示第 i 條褲子與多少件衣服不可搭配和多少條褲子與多少雙鞋子不可搭配(就是以褲子爲中間媒介)。最後只要遍歷 一遍所有的褲子,(n-c[i])*(k-s[i])就是每條褲子在滿足條件的情況下有多少種搭配方式,最後將所有的搭配求和爲ans即可。
<span style="font-size:18px;">#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;
const int maxn=1005;
bool vis1[maxn][maxn],vis2[maxn][maxn];
int c[maxn],s[maxn];
int main()
{
    int n,m,k,p,a,b;
    char str1[10],str2[10];
    while(~scanf("%d %d %d",&n,&m,&k) && n+m+k)
    {
        memset(vis1,false,sizeof(vis1));
        memset(vis2,false,sizeof(vis2));
        memset(c,0,sizeof(c));
        memset(s,0,sizeof(s));
        scanf("%d",&p);
        for(int i=0;i<p;i++){
            scanf("%s %d %s %d",&str1,&a,&str2,&b);
            if(str1[0]=='c' && str2[0]=='p')
            {
                if(!vis1[a][b]){
                    vis1[a][b]=true;
                    c[b]++;
                }
            }
            else{
                if(!vis2[a][b]){
                    vis2[a][b]=true;
                    s[a]++;
                }
            }
        }
        int ans=0;
        for(int i=1;i<=m;i++)
            ans+=(n-c[i])*(k-s[i]);
        printf("%d\n",ans);
    }
    return 0;
}
</span>

 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章