POJ-3122 Pie

J - Pie
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10−3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655


題目大意:有N塊蛋糕,F+1個人,每人只能分一塊(不能拿幾塊小的拼成大的),求每人最多拿多少體積(高相等,體積即面積)。
二分,代碼:

#include<iostream>
#include<cmath>
using namespace std;
int n,k,i,j;
double s[10005],pi=acos(-1.0);//pi的定義 
bool search(double a)
{
	int count=0;
	for(i=1;i<=n;i++)
		count+=s[i]/a;//按每人a體積,共能分幾塊 
	if(count>=k+1)
		return true;//超過人數,返回真 
	else
		return false;
}
int main()
{
	int t,temp;
	scanf("%d",&t);
	while(t--)
	{
		double mid=0.0,max=0.0,min=0.0;
		scanf("%d%d",&n,&k);
		for(i=1;i<=n;i++)
		{
			scanf("%d",&temp);
			s[i]=pi*temp*temp;
			max+=s[i];
		}
		max/=(k+1);
		while(max-min>1e-5)//精度 
		{
			mid=(max+min)/2.0;
			search(mid)?min=mid:max=mid;//如果search值爲真,即體積mid夠分,把mid賦值給min 
		}
		printf("%.4lf\n",mid);
	}
	return 0;
}





發佈了29 篇原創文章 · 獲贊 48 · 訪問量 7萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章