poj-3273 Monthly Expense

Monthly Expense
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 7707   Accepted: 3180

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M 
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

題目大意:知道農民接下來N天每天花的錢,不改變順序要分成M份。求最大一份的最小值是多少。
二分查找,代碼:






#include<iostream>  
using namespace std;  
int i,j,n,m,cxb[100010];  
bool fine(int a)  
{  
    int temp=0,x=1;  
    for(i=1;i<=n;i++)  
    {  
        if(x>m)  
            return false;  
        temp+=cxb[i];  
        if(temp>a)  
        {  
            temp=cxb[i];  
            x++;  
        }  
    }  
    if(x<=m)  
        return true;  
}  
int main()  
{  
    while(scanf("%d%d",&n,&m)!=EOF)  
    {  
        int sum=0,min=0,max,mid;  
        for(i=1;i<=n;i++)  
        {  
            scanf("%d",&cxb[i]);  
            sum+=cxb[i];  
            if(cxb[i]>min)  
                min=cxb[i]; //最小爲花的最多的那天 
        }  
        max=sum;//最大爲總的錢數 
        int ans; 
        while(max>=min)//進行二分查找  
        {  
            mid=(max+min)/2;  
            if(fine(mid))  
            {  
                max=mid-1;  
                ans=mid;  
            }  
            else  
            {  
                min=mid+1;  
            }  
        }  
        printf("%d\n",ans);  
    }  
    return 0;  
} 





發佈了29 篇原創文章 · 獲贊 48 · 訪問量 7萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章