【單調隊列】HDU_3706_Second My Problem First

Second My Problem First

Time Limit: 12000/4000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1931    Accepted Submission(s): 734


Problem Description
Give you three integers n, A and B.
Then we define Si = Ai mod B and Ti = Min{ Sk | i-A <= k <= i, k >= 1}
Your task is to calculate the product of Ti (1 <= i <= n) mod B.
 

Input
Each line will contain three integers n(1 <= n <= 107),A and B(1 <= A, B <= 231-1).
Process to end of file.
 

Output
For each case, output the answer in a single line.
 

Sample Input
1 2 3 2 3 4 3 4 5 4 5 6 5 6 7
 

Sample Output
2 3 4 5 6
 

Author
WhereIsHeroFrom@HDU
 

Source
 

Recommend
lcy
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
typedef long long LL;
const int maxn=1e6+1;
LL s[maxn],q[maxn],b;
int main()
{
    LL n, a;
    while(~scanf("%lld%lld%lld",&n,&a,&b)){
        LL front=0,rear=0;
        LL ans=1,x=1;
        for(LL i=1;i<=n;i++){
            LL l=max(1LL,i-a);
            x=x*a%b;
            while(front<rear&&x<s[rear-1])
                rear--;
            s[rear]=x;
            q[rear++]=i;
            while(front<rear&&l>q[front])
                front++;
            ans=ans*s[front]%b;
        }
        printf("%lld\n",ans);
    }
    return 0;
}

發佈了60 篇原創文章 · 獲贊 1 · 訪問量 9917
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章