poj2253青蛙(可到達路徑的單次跳躍最短距離)

Frogger

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 55388 Accepted: 17455

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414
傳送門:點擊打開鏈接
題目大意:一隻青蛙要從點1到點2,給你n個座標,問你青蛙要達到終點,單次跳躍的最短距離是多少。

思路:一開始想到二分,感覺很麻煩,然後想到djkstra算法裏的dis【】,一般我們用這個dis表示從起點點集到某一個點的最短總距離,現在我們可以用dis來表示,從起點點集到某一個點單次跳躍的最短距離,所以有了

for(int j=1;j<=n;j++){
		if(!vis[j])
		dis[j]=min(dis[j],max(g[p][j],dis[p]));
	}

其實就是用三角形,1,p,j三個點,dis【j】要麼是本身,要麼是另外兩條邊最大的那一條。

核心思想就是這樣,其他的沒什麼坑點了。然後上完整代碼。

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<string>
#include<math.h>
#include<cmath>
#include<time.h>
#include<map>
#include<set>
#include<vector>
#include<queue>
#include<algorithm>
#include<numeric>
#define ll long long
using namespace std;
const int maxn=210;
const int INF=0x3f3f3f3f;
struct dian {
	double x,y;
} a[maxn];
double g[maxn][maxn];
double dis[maxn];
int vis[maxn],n;
void djks(){
	for(int i=1;i<=n;i++){
		dis[i]=g[1][i];
	}
	memset(vis,0,sizeof(vis));
	vis[1]=1;
	for(int i=1;i<n;i++){
		double minn=INF;
		int p;
		for(int j=1;j<=n;j++){
			if(!vis[j]&&dis[j]<minn){
				p=j;
				minn=dis[j];
			}
		}
		vis[p]=1;
		for(int j=1;j<=n;j++){
			if(!vis[j])
			dis[j]=min(dis[j],max(g[p][j],dis[p]));//核心 用三角形的思路來鬆弛 
		}
	}
}
int main() {
	int cas=1;
	while(scanf("%d",&n),n) {
		memset(g,INF,sizeof(g));
		for(int i=1; i<=n; i++) {
			scanf("%lf%lf",&a[i].x,&a[i].y);
		}
		for(int i=1; i<=n; i++) {
			for(int j=1; j<=n; j++) {
				double x=a[i].x-a[j].x;
				double y=a[i].y-a[j].y;
				g[i][j]=g[j][i]=pow(x*x+y*y,0.5);
			}
		}
		djks();
		printf("Scenario #%d\n",cas++);
		printf("Frog Distance = %.3f\n\n",dis[2]);
	}
}

發佈了40 篇原創文章 · 獲贊 0 · 訪問量 5213
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章