1140 Look-and-say Sequence (20分)

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1’s, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1 8  

Sample Output:

1123123111

首先看看樣例是怎麼變成1123123111的

  1. 1
  2. 11
  3. 12
  4. 1121
  5. 122111
  6. 112213
  7. 12221131
  8. 1123123111

本題要點:

  1. string 只能用 cin cout 輸入輸出,不能使用 scanf 與 printf
  2. t = t +…與 t+=… 後者效率較高
  3. to_string()將數字轉爲字符串
#include <iostream>
#include <string>

using namespace std;

int main() {
    int N, j;
    string s;
    cin >> s >> N;
    for(int cnt = 1;cnt < N; cnt++){
        string t;
        for(int i = 0; i < s.length(); i = j){
            for(j = i; j < s.length() && s[j] == s[i]; j++);
            t += s[i] + to_string(j - i); //如果使用t=t+...會超時
        }
        s = t;
    }
    cout << s;
    return 0;
}
發佈了69 篇原創文章 · 獲贊 6 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章