並查集

http://vjudge.net/contest/view.action?cid=49839#problem/A

A - A
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers. 

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table. 

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least. 
 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases. 
 

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks. 
 

Sample Input

2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output

2 4
 


加入了壓縮路徑





#include<stdio.h>  
#include<stdlib.h>  
#include<algorithm>  
#include<iostream>  
using namespace std;  
int m,n,parent[20000];

void UFset()//初始化
{
	for(int i=1;i<=m;i++)
		parent[i]=-1;

}
int Find(int x)
{
	
	int s;//查找位置,一直找到parent[s]爲負數爲止
	for(s=x;parent[s]>=0;s=parent[s]);
	
		while(s!=x)
		{
			int tmp=parent[x];//優化方案,壓縮路徑,更新子節點
			parent[x]=s;
			x=tmp;
		}
	
	return s;
}

void Union( int R1,int R2 )
{

	int r1=Find(R1),r2=Find(R2);
	
	int tmp=parent[r1]+parent[r2];//兩個集合結點個數之和(負數)
		if(parent[r1]>parent[r2])//優化方案--加權法則
		{
			parent[r1]=r2;//根節點r1所在的樹作爲r2的子樹
			parent[r2]=tmp;
		}
		else
		{
			parent[r2]=r1;//<span style="font-family: Arial, Helvetica, sans-serif;">//根節點r2所在的樹作爲r1的子樹</span>
			parent[r1]=tmp;
		}
}
int main()
{
	int N;
	scanf("%d",&N);
	while(N--)
	{
		scanf("%d%d",&m,&n);
		UFset();
		int a,b;

		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&a,&b);
			if(Find(a) != Find(b))//這裏要進行判斷父節點不等,才經行合併
				Union(a,b);
		}
		int num=0;
		for(int i=1;i<=m;i++)
		{
			if(parent[i]<0)
				num++;
		}
		printf("%d\n",num);
	}
	return 0;
}









發佈了65 篇原創文章 · 獲贊 3 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章