N!

/*Crawling in process... Crawling failed Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit Status
Description

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

 
Input

One N in one line, process to the end of file.

 
Output

For each N, output N! in one line.

 
Sample Input

1
2
3
Sample Output

1
2
6
*
#include<stdio.h>
#include<string.h>
const int max= 50000;
int f[max];
int main()
{
 int i,j,n;
 while(scanf("%d",&n)!=EOF)
 {
  memset(f,0,sizeof(f));
  f[0]=1;
  for(i=2;i<=n;i++)
  {
   int c=0;
   for(j=0;j<max;j++) //存到數組裏。
   {
    int s=f[j]*i+c;
    f[j]=s%10;
    c=s/10;
   }
  }
  for(j=max-1;j>=0;j--) //輸出那個數組。
   if(f[j])
    break;
  for(i=j;i>=0;i--)
   printf("%d",f[i]);
  printf("\n");
 }
 return 0;
}*/

#include <stdio.h> 
#include<iostream>
#include<string.h>
using namespace std;
#define N 10001 //計算N的階乘,修改N的定義可計算10000以內任意數的階乘     
long a[N],n,i,c,m;
int main()
{
 while(scanf("%d",&n)!=EOF)
 {
  memset(a,0,sizeof(a));
  a[0]=1;
  m=0;
  for(;n>1;(a[i]=c)>0?m++:0,n--)//m是最高位
  {
   for(c=0,i=0;i<=m;i++)//c爲累加保存的進位
   {
    a[i]=(c+=a[i]*n)%10000;
    c/=10000;
   }
  }
  for(printf("%d",a[m]);--m>=0;)
   printf("%04d",a[m]);
  printf("\n");
  
 }
 return 0;


點擊打開鏈接
#include<stdio.h>
#include<string.h>
#define N 50000    //計算N的階乘,最多隻能算到9999
long a[N],n,i,c,m;
int main()
{
    while(scanf("%d",&n)!=EOF)
 {
  memset(a,0,sizeof(a));
  a[0]=1;
  m=0;
  for ( ;n>1; (a[i]=c)>0?m++:0,n--)
  {
   for (c=0,i=0; i<=m;i++)
   {
    
    a[i]= (c+=a[i]*n)%10000;
    c/=10000;
   }
  }
 
  printf("%d",a[m]);
  for( m--;m>=0;m--)
   printf("%04d",a[m]);
  printf("\n");
 
 }
    return 0;
}

發佈了45 篇原創文章 · 獲贊 6 · 訪問量 9萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章