-----廣搜 POJ 3278-Catch That Cow

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

#include<iostream>
#include<queue>
#include<cstring>
#include<cstdio>
using namespace std;

const int maxn=100001;

int vis[maxn],time[maxn];///vis[i]標記i點是否被訪問過,time[i]
int n,k;
queue<int>que;

int bfs(int n,int k)
{
    int head,next;
    que.push(n);///n入隊
    vis[n]=1;///n點已經被走過了
    time[n]=0;///到達n點的時候走了0步
    while(!que.empty())///當隊列非空的時候
    {
        head=que.front();///取出隊首元素
        que.pop();
        for(int i=0;i<3;i++)///三種操作
        {
            if(i==0) next=head+1;
                else if(i==1) next=head-1;
                else next=head*2;
            if(next<0||next>=maxn) continue;
            if(vis[next]==0)
            {
                que.push(next);///next入隊
                vis[next]=1;///標記next爲已經訪問過了
                time[next]=time[head]+1;///時間爲上一次操作加一
            }
            if(next==k) return time[next];///到達目的地
    }
}
}
int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        memset(vis,0,sizeof(vis));
        memset(time,0,sizeof(time));
        if(n>=k) printf("%d\n",n-k);
        else printf("%d\n",bfs(n,k));
    }
}
發佈了53 篇原創文章 · 獲贊 14 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章