mooc浙大數據結構PTA習題之Reversing Linked List

02-線性結構3 Reversing Linked List(25 分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

 

參考代碼(未評分,僅結果正確):

#include<iostream>
using namespace std;
struct node1
{
	int data;
	int next;
};
struct node2
{
	int address;
	int data;
	int nextaddr;
	struct node2*next;
};

void attach(int a, int b, int c,node2 **rear)
{
	node2 *p = new node2;
	p->address = a;
	p->data = b;
	p->nextaddr = c;
	p->next = NULL;
	(*rear)->next = p;
	*rear = p;
}

int main()
{
	int addr, n,k;
	int a, b, c;
	node1 sss[100000];
	cin >> addr >> n >> k;
	while (n--)
	{
		cin >> a >> b >> c;
		sss[a].data = b;
		sss[a].next = c;
	}

	int p = addr;
	node2 *rear;
	node2 *t;
	node2 *head = new node2;
	head->next = NULL;
	rear = head;
	while (p != -1)
	{
		attach(p, sss[p].data, sss[p].next, &rear);
		p = sss[p].next;
	}
	
	node2 *neww, *oldd, *tempp;
	neww = head->next;
	oldd =neww->next;
	
	while((k--)-1)
	{
		tempp = oldd->next;
		oldd->next = neww;
		neww = oldd;
		oldd = tempp;
		
	}
	head->next->next = oldd;
	head->next = neww;

	t = head;
	head = head->next;
	delete t;

	while(head != NULL)
	{
		if (head->next != NULL)
		{
			cout << head->address << " " << head->data << " " << head->next->address << endl;
		}
		else
			cout << head->address << " " << head->data << " " << "-1" << endl;
		head =head->next;

	}
	system("pause");
	return 0;
}

 

最初難點在於如何將所輸入的數據存儲於一個單鏈表中,本代碼開闢了一個非常大的數組,用於存儲較少的數據,造成了浪費。應該還能繼續優化,不使用數組存儲輸入的數據。目前代碼還需優化。

更新:上面的代碼是錯的,滿分在此:

https://blog.csdn.net/wss123wsj/article/details/82153599

發佈了47 篇原創文章 · 獲贊 13 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章