SGU126-Boxes

126. Boxes

time limit per test: 0.5 sec.
memory limit per test: 4096 KB

There are two boxes. There are A balls in the first box, and B balls in the second box (0 < A + B < 2147483648). It is possible to move balls from one box to another. From one box into another one should move as many balls as the other box already contains. You have to determine, whether it is possible to move all balls into one box. 

Input

The first line contains two integers A and B, delimited by space.

Output

First line should contain the number N - the number of moves which are required to move all balls into one box, or -1 if it is impossible.

Sample Input

Sample Output

2 6

Sample Output

2



 

按照題意模擬、若是循環的次數很大、則是屬於不符合要求的了。

 

 

 

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<ctype.h>
#include<algorithm>
#include<stack>
#include<queue>
#include<set>
#include<math.h>
#include<vector>
#include<map>
#include<deque>
#include<list>
using namespace std;
int main()
{
    int a,b;
    int count;
    while(scanf("%d%d",&a,&b)!=EOF)
    {
        count=0;
        while(a&&b)
        {
            if(a>b)
                swap(a,b);
            b-=a;
            a+=a;
            count++;
            if(count>64*64)
                break;
        }
        if(count>(64*64))
            printf("-1\n");
        else
            printf("%d\n",count);
    }
    return 0;
}


 

 

 

 

 

發佈了239 篇原創文章 · 獲贊 42 · 訪問量 42萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章