hdu 1017 A Mathematical Curiosity

                                                       A Mathematical Curiosity

                             Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

暴力求解,主要是注意格式。。。空格有點坑。。

Description

Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

Input

You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
 

Output

For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
 

Sample Input

1 10 1 20 3 30 4 0 0
 

Sample Output

Case 1: 2 Case 2: 4 Case 3: 5
 
#include <iostream>
#include<cstdio>
using namespace std;

int main()
{
    int x;
    scanf("%d",&x);
    while(x--)
    {
        int n,m;
        int cas=0;
        while(scanf("%d%d",&n,&m)!=EOF)
        {
            cas++;
            if(n==0&&m==0) break;
            int count=0,i,j;
            for(i=1;i<n;i++)for(j=i+1;j<n;j++)if((i*i+j*j+m)%(i*j)==0) count++;
            printf("Case %d: %d\n",cas,count);
        }
        if(x!=0) printf("\n");
    }
    return 0;
}

發佈了28 篇原創文章 · 獲贊 2 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章