【HDU】 4763 Theme Section (KMP)

Theme Section

Problem Description
It's time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a 'theme section'. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of 'EAEBE', where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters 'a' - 'z'.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?
 

 

Input
The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.
 

 

Output
There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.
 

 

Sample Input
5 xy abc aaa aaaaba aaxoaaaaa
 

 

Sample Output
0 0 1 1 2

1、先求出S串的next數組。
2、然後從next[n]開始,如果next[n]<=n/3,然後從n/3+1開始到n-next[n]用kmp,判斷是否存在1~next[n]的子串。如果不存在則繼續往前找。

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;

void kmp_pre(char x[],int m,int next[])
{
    int i,j;
    j = next[0] = -1;
    i = 0;
    while(i < m)
    {
        while( -1 != j && x[i] != x[j] )j = next[j];
        next[++i] = ++j;
    }
}
char str[1000010];
int next[1000010];
bool f[1000010];
int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",str);
        int n = strlen(str);
        kmp_pre(str,n,next);
        memset(f,false,sizeof(f));
        int tmp = n;
        while(tmp > 0)
        {
            if(n >= 2*tmp)f[tmp] = true;
            tmp = next[tmp];
        }
        int ans = 0;
        for(int i = n-1;i > 1;i--)
        {
            tmp = i;
            while(tmp > 0)
            {
                if(f[tmp] && i >= 2*tmp && n >= i+tmp)
                {
                    ans = max(ans,tmp);
                    break;
                }
                tmp = next[tmp];
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

—————————————————————————————————

本文原創自Sliencecsdn技術博客。

本博客所有原創文章請以鏈接形式註明出處。

歡迎關注本技術博客,本博客的文章會不定期更新。


大多數人想要改造這個世界,但卻罕有人想改造自己。

世上沒有絕望的處境,只有對處境絕望的人。

                                              ————By slience

—————————————————————————————————


發佈了184 篇原創文章 · 獲贊 48 · 訪問量 31萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章