problem-1006 Elevator 解題報告

Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

 

Output
Print the total time on a single line for each test case. 
 

 

Sample Input
1 2 3 2 3 1 0
 

 

Sample Output
17 41
 
原始樓層是一樓,電梯上升一層爲6秒,下降一層是4秒,每次升降停頓時間爲5秒,求總花費時間=總共上升的樓層數*6+總共下降的樓層數*4+升降的次數*5
樓層不變另算
ac代碼:
</pre><pre name="code" class="cpp">#include<cstdio>
#include<iostream>
#include<cmath>
using namespace std;
int main(){
int n,m,i,a,sum;
while(cin>>n)
{
if(n==0) break;
cin>>m;
if(n==1) {cout<<6*m+5<<endl;continue;}
a=m;
sum=6*m;
for(i=1;i<n;i++)
{
cin>>m;
if(a>m) sum+=4*(a-m);
else sum+=6*(m-a);
a=m;
}
sum=sum+5*n;
cout<<sum<<endl;
}
    return 0;
}



發佈了33 篇原創文章 · 獲贊 0 · 訪問量 7481
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章