1010. Radix (25)

1010. Radix (25)

時間限制
400 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag" is 1, or of N2 if "tag" is 2. 

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.

Sample Input 1:
6 110 1 10
Sample Output 1:
2
Sample Input 2:
1 ab 1 2
Sample Output 2:
Impossible
這個問題的難點在於int會越界,就算是long也有可能越界,部分代碼參照了http://blog.csdn.net/acm_ted/article/details/20293167
//
//  main.cpp
//  Test
//
//  Created by 秦傳慶 on 16/2/25.
//  Copyright © 2016年 秦傳慶. All rights reserved.
//

#include <iostream>
#include <string>
#include <algorithm>
#include <vector>
#include <sstream>

using namespace std;

int charToInt(char datain)
{
    int result = 0;
    if (datain >= 'a' && datain <= 'z'){
        result = datain - 'a' + 10;
    }
    else {
        result = datain - '0';
    }
    return result;
}

long anyToDecimal(string datain, long radix){
    long digit = 0;
    long radix_temp = 1;
    long number = 0;
    for (int index = static_cast<int>(datain.size()) - 1; index >= 0; index--){
        number = charToInt(datain[index]);
        digit += number * radix_temp;
        radix_temp *= radix;
        if (digit < 0){ //
            return -1;
        }
    }
    return digit;
}

int radixMayBe(string datain){
    int min_radix = 0;
    for (int i = 0; i < datain.size(); i++){
        min_radix = max(min_radix, charToInt(datain[i]));
    }
    return min_radix + 1;
}

bool binary_search(long N1, string N2, long& lower, long& upper){
    long temp;
    long middle = 0;
    bool result = false;
    while (lower <= upper){
        middle = (lower + upper) / 2;
        
        temp = anyToDecimal(N2, middle);
        if (temp > N1 || -1 == temp){
            upper = middle - 1;
        }
        else if (temp < N1){
            lower = middle + 1;
        }
        else {
            result = true;
            break;
        }
        //cout << lower << ":" << middle << ":" << upper << endl;
    }
    if (result){
        cout << middle << endl;
    } else {
        cout << "Impossible" << endl;
    }
    return result;
}

int main() {
    string N1;
    long N1_long = 0;
    string N2;
    int tag;
    long radix;
    cin >> N1;
    cin >> N2;
    cin >> tag;
    cin >> radix;
    if (2 == tag){
        swap(N1, N2);
    }
    N1_long = anyToDecimal(N1, radix);
    long min_radix = radixMayBe(N2);
    long max_radix = N1_long + 1;
    binary_search(N1_long , N2, min_radix, max_radix);
    //cout << anyToDecimal("ff", 17) << endl;
    return 0;
}


發佈了58 篇原創文章 · 獲贊 18 · 訪問量 6萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章