Fliptile POJ - 3279 開關問題

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input
Line 1: Two space-separated integers: M and N
Lines 2.. M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white
Output
Lines 1.. M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.
Sample Input
4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1
Sample Output
0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0


思路:當一個格子被翻轉偶數次與原來的相同,所以多次翻轉是無用的;

          每一行的翻轉必然會影響到下一行,可知第一行的翻轉狀態數有2^m,枚舉第一行的翻轉狀態,下一行受上一行的影響,如果正上方是1,則翻轉此格。保證前n-1行都爲0;

最後只需要判斷最後一行是否全爲0,就這一說明這種狀態是否可行。。


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int M=16;
int n,m,cnt;
int maps[M][M],ans[M][M],a[M][M];
int dx[4]={1,-1,0,0};
int dy[4]={0,0,-1,1};
bool check(int x,int y)
{
    if(x<0||x>n||y<0||y>m)
        return 0;
    return 1;
}
void flip(int x,int y)
{
    cnt++;
    a[x][y]=!a[x][y];
    ans[x][y]=1;
    for(int i=0;i<4;i++)
    {
        int nx=x+dx[i],ny=y+dy[i];
        if(check(nx,ny))
            a[nx][ny]=!a[nx][ny];
    }
}
bool solve(int k)
{
    memcpy(a,maps,sizeof(a));//內存拷貝函數
    for(int i=0;i<m;i++)
        if(k&(1<<(m-i-1)))
            flip(0,m-i-1);
    for(int i=1;i<n;i++)
        for(int j=0;j<m;j++)
        if(a[i-1][j])
            flip(i,j);
    for(int j=0;j<m;j++)
        if(a[n-1][j])
        return 0;
    return 1;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
            scanf("%d",&maps[i][j]);
        int f=-1,ans1=0x3f3f3f3f;
        for(int i=0;i<(1<<m);i++)
        {
            cnt=0;
            if(solve(i)&&ans1>cnt)
            {
                ans1=cnt;f=i;
            }
        }
        memset(ans,0,sizeof(ans));
        if(f>=0)
        {
            solve(f);
            for(int i=0;i<n;i++)
                for(int j=0;j<m;j++)
                printf("%d%c",ans[i][j],j==(m-1)?'\n':' ');
        }
        else
        printf("IMPOSSIBLE\n");
    }
    return 0;
}


發佈了120 篇原創文章 · 獲贊 9 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章