【題解】HDU 1075 What Are You Talking About

題目描述

目錄

題目描述

題意分析

AC代碼


Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)

Problem Description

Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

Output

In this problem, you have to output the translation of the history book.

Sample Input

START

from fiwo

hello difh

mars riwosf

earth fnnvk

like fiiwj

END

START

difh, i'm fiwo riwosf.

i fiiwj fnnvk!

END

 

Sample Output

hello, i'm from mars.

i like earth!

 

題意分析

題意:給你 地球語 以及 相對應的火星語 ,叫你把火星語翻譯一下輸出。

           STL MAP,截取單詞,並於MAP中尋找,若找到則轉化輸出即可

           要求使用scanf 但我一直編譯錯誤,用了cin就OK 了,有思路的同學,歡迎下方留言

 

AC代碼

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
#include <map>
using namespace std;

map <string,string> s;

int main()
{
    string q,p,r;       
    string s2,s3;
    int i;

    cin>>r;
    while( cin>>p )
    {
        if(p=="END")break;

        cin>>q;
        s[q] = p;
    }

    cin>>r;
    getline(cin,s2);
    while(getline(cin,s2))
    {
        if(s2=="END")break;
        s3="";
        for(i=0;i<s2.size();i++)
        {
            if( isalpha(s2[i]) )
            {
                s3+=s2[i];
            }
            else                    //於MAP中搜索判定  
            {
                if(s[s3]!="")
                {
                    cout<<s[s3];
                }
                else
                {
                    cout<<s3;
                }
                cout<<s2[i];       //須將此將非字母輸出  並將字符串賦空
                s3="";
            }
        }
        cout<<endl;
    }
    return 0;
}

 

發佈了50 篇原創文章 · 獲贊 7 · 訪問量 5989
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章