POJ - 1611 The Suspects(並查集)

The Suspects
Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 45803 Accepted: 21941

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Code

#include <cstdio>
#include <cstring>
#define N 30000

using namespace std;

int pre[N];

void Init(int n)
{
    for(int i=0; i<n; i++)
    {
        pre[i] = i;
    }
}

int find(int x)
{
    if(pre[x] == x)
        return pre[x];
    return pre[x] = find(pre[x]);
}

void join(int a, int b)
{
    a = find(a);
    b = find(b);
    if(a != b)
    {
        pre[b] = a;
    }
}

int main()
{
    int n,m,k,boss,p;
    while(~scanf("%d %d",&n,&m) && (n || m))
    {
        Init(n);
        int sum = 0;
        while(m--)
        {
            scanf("%d %d",&k,&boss);
            for(int i=0; i<k-1; ++i)
            {
                scanf("%d",&p);
                join(boss,p);
            }
        }
        for(int i=0; i<n; ++i)
        {
            if(find(i) == pre[0])   ///0號學生是感染者
            {
                sum++;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

反思:

題目大意:爲了防止SARS擴散,學校決定隔離疑似感染者。一個學生可能參加多個社團,當一個社團中有一個疑似感染者時,全社團人員都要被隔離。每個學生都有一個唯一的編號,已知0號學生是感染者,現在要找出所有疑似感染者的數量。n爲學生數量,m爲社團數量,接下來m行第一個數k爲該社團的人數,之後爲該社團的學生編號,多組輸入,當n和m同時爲0時結束輸入。

並查集問題,判斷條件爲學生的祖先結點和0號學生的相同。

發佈了112 篇原創文章 · 獲贊 8 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章