1014_排名

// 1014_排名.cpp : 定义控制台应用程序的入口点。
//题目1014:排名
//时间限制:1 秒内存限制:32 兆特殊判题:否提交:9152解决:2758
//题目描述:
//    今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的考生,并将他们的成绩按降序打印。
//输入:
//    测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N < 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号(题目号由1到M)。 
//    当读入的考生人数为0时,输入结束,该场考试不予处理。
//输出:
//    对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考号的升序输出。
//样例输入:
//4 5 25
//10 10 12 13 15
//CS004 3 5 1 3
//CS003 5 2 4 1 3 5
//CS002 2 1 2
//CS001 3 2 3 5
//1 2 40
//10 30
//CS001 1 2
//2 3 20
//10 10 10
//CS000000000000000001 0
//CS000000000000000002 2 1 2
//0
//样例输出:
//3
//CS003 60
//CS001 37
//CS004 37
//0
//1
//CS000000000000000002 20
//来源:
//2005年浙江大学计算机及软件工程研究生机试真题

#include "stdafx.h"
#include "stdio.h"
#include "string.h"
#include "stdlib.h"

#define maxN 1001
#define maxM 12
#define maxG 100

struct student{
    char id[22];
    int problem[maxM];  //答对的题目及分值
    int score;         
    int npro;          //答对的题目数
    int isPass;
}student[maxN],student2[maxN];

int compare(const void *p,const void *q)
{
    struct student *p1 = (struct student *)p;
    struct student *q1 = (struct student *)q;
    if((*p1).score == (*q1).score)
        return strcmp((*p1).id,(*q1).id);
    else
        return (*q1).score - (*p1).score;
}

int main()
{
    int N,M,G;
    while(scanf("%d",&N)!=EOF)
    {
        if(!N)
            break;
        else
        {
            int n=0;
            scanf("%d %d",&M,&G);
            int prob[maxM];
            for(int i=1;i<=M;i++)
                scanf("%d",&prob[i]);
            for(int i=1;i<=N;i++)
            {
                student[i].score = 0;
                student[i].isPass = 0;
                scanf("%s %d",student[i].id,&student[i].npro);
                int temp;
                for(int j=1;j<=student[i].npro;j++)
                {
                    scanf("%d",&temp);
                    student[i].score += prob[temp];             
                }
                if (student[i].score>=G)
                {
                    student2[n] = student[i];
                    n++;
                    student[i].isPass = 1;
                }
            }
            qsort(student2,n,sizeof(student2[0]),compare);
            printf("%d\n",n);
            for(int k = 0;k<n;k++)
                printf("%s %d\n",student2[k].id,student2[k].score);
        }
    }
    return 0;
}

发布了60 篇原创文章 · 获赞 0 · 访问量 1万+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章