hdu 1220 Cube

傳送門

Cowl is good at solving math problems. One day a friend asked him such a question: You are given a cube whose edge length is N, it is cut by the planes that was paralleled to its side planes into N * N * N unit cubes. Two unit cubes may have no common points or two common points or four common points. Your job is to calculate how many pairs of unit cubes that have no more than two common points.

Process to the end of file.

Input

There will be many test cases. Each test case will only give the edge length N of a cube in one line. N is a positive integer(1<=N<=30).

Output

For each test case, you should output the number of pairs that was described above in one line.

Sample Input

1
2
3

Sample Output

0
16
297

【題意】

給你一個n*n*n的立方體,問你有多少對立方體,他們的頂點相同數小於等於2.

【分析】

顯然可以得到頂點相同數量只能爲0,1,2,4.所以我們用容斥來做。直接統計所有的對數,也就是sum*(sum-1)/2。然後減掉有四個頂點的。稍微分析一下就知道有四種情況,分別統計一下就行了。

【代碼】

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<cmath>
#include<map>
#include<time.h>
#include<bits/stdc++.h>
using namespace std;
int main()
{
//    freopen("in.txt","w",stdout);
    int a;
    while(cin>>a)
    {
        if(a==1)
        {
            puts("0");
            continue;
        }
        long long sum = a*a*a;
        long long ans = (sum*(sum-1))>>1;
        long long jiao = 8*3;
        long long leng = 12*(a-2)*4;
        long long mian = 6*(a-2)*(a-2)*5;
        long long li = (a-2)*(a-2)*(a-2)*6;
        ans-=(jiao+leng+mian+li)>>1;
        cout<<ans<<endl;
    }
    return 0;
}
發佈了182 篇原創文章 · 獲贊 5 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章