【POJ】1088.滑雪

Description

Michael喜歡滑雪百這並不奇怪, 因爲滑雪的確很刺激。可是爲了獲得速度,滑的區域必須向下傾斜,而且當你滑到坡底,你不得不再次走上坡或者等待升降機來載你。Michael想知道載一個區域中最長底滑坡。區域由一個二維數組給出。數組的每個數字代表點的高度。下面是一個例子
 1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

一個人可以從某個點滑向上下左右相鄰四個點之一,當且僅當高度減小。在上面的例子中,一條可滑行的滑坡爲24-17-16-1。當然25-24-23-...-3-2-1更長。事實上,這是最長的一條。

Input

輸入的第一行表示區域的行數R和列數C(1 <= R,C <= 100)。下面是R行,每行有C個整數,代表高度h,0<=h<=10000。

Output

輸出最長區域的長度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25


思路:

動態規劃


代碼:

import java.util.Scanner;

public class Main {
	static int[][] map = new int[100][100];
	static int r , c ;
	
	public static int dfs(int i, int j){
		int max = 1;
		int a1 = 0;

		if(i > 0 && map[i][j] > map[i-1][j]){
			a1 = dfs(i-1,j) + 1;
			max = max > a1 ? max : a1;
		}
		if(j > 0 && map[i][j] > map[i][j-1]){
			a1 = dfs(i,j-1) + 1;
			max = max > a1 ? max : a1;
		}
		if(i < r-1 && map[i][j] > map[i+1][j]){
			a1 = dfs(i+1,j) + 1;
			max = max > a1 ? max : a1;
		}
		if(j < c-1 && map[i][j] > map[i][j+1]){
			a1 = dfs(i,j+1) + 1;
			max = max > a1 ? max : a1;
		}
		
		return max;
	}	
	
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int[][] dp = new int[100][100];
		while (sc.hasNext()) {
			r = sc.nextInt();
			c = sc.nextInt();

			for (int i = 0; i < r; i++) {
				for (int j = 0; j < c; j++) {
					map[i][j] = sc.nextInt();
	//				System.out.println("input" + map[i][j]);
					dp[i][j] = 0;
				}
			}
	//		System.out.println(map);
			int max = 0;
			for (int i = 0; i < r; i++) {
				for (int j = 0; j < c; j++) {
					if (dp[i][j] != 0)
						continue;
					dp[i][j] = dfs(i, j);
					if (dp[i][j] > max)
						max = dp[i][j];
				}
			}
			System.out.println(max);
		}

	}
}


問題:爲什麼要把全局變量設置成靜態的?還有方法。

而且,爲什麼poj上過不了。。。




發佈了65 篇原創文章 · 獲贊 26 · 訪問量 23萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章