1115 Counting Nodes in a BST (30分) 簡單的二叉搜索樹(建樹和求高度)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node's key.
  • The right subtree of a node contains only nodes with keys greater than the node's key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−10001000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

Sample Output:

2 + 4 = 6

作者: CHEN, Yue

單位: 浙江大學

時間限制: 400 ms

內存限制: 64 MB

#include <bits/stdc++.h>
using namespace std;
const int maxn = 10000;
struct node
{
    node *l, *r;
    int val;
    int h;
};
node* built(node* root, int val)
{
    if(root==NULL)
    {
        root = new(node);
        root->val = val;
        root->l = NULL;
        root->r=NULL;
    }
    else if(val<=root->val)
    {
        root->l = built(root->l, val);
    }
    else if(val>root->val)
    {
        root->r = built(root->r, val);
    }
    return root;
}
int mx=-1;
int num[maxn];
void dfs(node* root, int h)
{
    if(root==NULL)
    {
        mx = max(mx, h); return;
    }
    num[h]++;
    dfs(root->l, h+1);
    dfs(root->r, h+1);
}
int main()
{
    int n, x;
    cin>>n;
    node* root = NULL;
    for(int i=0; i<n; i++)
    {
        cin>>x;
        root = built(root, x);
    }
    //printf("%d\n", root->val);
    dfs(root, 1);
    printf("%d + %d = %d\n", num[mx-1], num[mx-2], num[mx-1]+num[mx-2]);
    return 0;
}

 

發佈了59 篇原創文章 · 獲贊 4 · 訪問量 5657
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章