Bone Collector

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22145    Accepted Submission(s): 8969


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
14  
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>

using namespace std;

struct Node
{
    int p,h;
}node[1001];

bool cmp(Node a,Node b)
{
    return (double)a.p/a.h > (double)b.p/b.h;
}

long long dp[1001];
int main()
{
    int T;
    while(scanf("%d",&T)!=EOF)
    {
        while(T--)
        {
            int n,v;
            scanf("%d%d",&n,&v);
            for(int i=0;i<n;i++)
            scanf("%d",&node[i].p);
            for(int i=0;i<n;i++)
            scanf("%d",&node[i].h);
            sort(node,node+n,cmp);
            memset(dp,0,sizeof(dp));
            for(int i=0;i<n;i++)
            {
                for(int j=v;j>=node[i].h;j--)
                dp[j]=max(dp[j],dp[j-node[i].h]+node[i].p);
            }
            printf("%lld\n",dp[v]);
        }
    }
    return 0;
}
發佈了41 篇原創文章 · 獲贊 3 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章