HDU 1072

Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
 

Output

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
 

Sample Input

3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
 

Sample Output

 4
-1
13 

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
int a,b,c,tu[10][10],x,y;
int dir1[4]={-1,0,1,0},dir2[4]={0,1,0,-1},vis[10][10][7];
struct weizhi
{
    int x,y,step,time;
    weizhi(int a,int b,int c,int d):x(a),y(b),step(c),time(d){}
};
bfs(int x,int y)
{
    weizhi X(x,y,0,6);
    queue <weizhi> dui;
    dui.push(X);
    while(!dui.empty())
    {
        int Time,tep;
        weizhi A=dui.front();
        dui.pop();
        for(int i=0;i<4;i++)
        {Time=A.time-1;//一開始這句代碼寫在了for循環上面,這個bug害得我找了半個小時,bug問題出在:假如父節點有四個子節點,第一個子節點觸發了更新時間
            x=A.x+dir1[i];y=A.y+dir2[i];//那麼其餘的三個節點就公用了第一個子節點的時間time
            if(Time==1&&tu[x][y]!=3&&tu[x][y]!=4)continue;
            if(x<1||x>b||y<1||y>c||tu[x][y]==0)continue;
            if(tu[x][y]==4)Time=6;
            tep=A.step+1;
            if(vis[x][y][Time])continue;
            vis[x][y][Time]=1;
            if(tu[x][y]==3)return tep;
            dui.push(weizhi(x,y,tep,Time));
        }
    }
    return -1;
}
int main()
{
    scanf("%d",&a);
    while(a--)
    {
        memset(vis,0,sizeof(vis));
        scanf("%d%d",&b,&c);
        for(int i=1;i<=b;i++)
            for(int l=1;l<=c;l++)
        {
            scanf("%d",&tu[i][l]);
            if(tu[i][l]==2)
            {x=i;y=l;}
        }
        vis[x][y][6]=1;
        int n=bfs(x,y);
        printf("%d\n",n);
    }
}

發佈了21 篇原創文章 · 獲贊 13 · 訪問量 6855
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章