PAT 甲級 1147 Heaps (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

算法思路
1、預選堆類型,判斷可能是大根堆還是小根堆。
2、建立完全二叉樹。
3、判斷是否滿足堆的條件(小根堆,當前結點的孩子均不大於它;大根堆,當前結點的孩子均不小於它)
4、格式話輸出
如果這篇博文對你的學習有所幫助,麻煩您點個贊啦?,這是對博主最大的支持啦,比心 ?

#include <iostream>
#include <cstdio>
using namespace std;
int M,N;
int arr[1005];
bool flag;
bool heap;
bool first;
struct node{
    int data;
    node *lchild,*rchild;
};
void creatHeap(node* &curr,int t)
{
    if(t>N)
        return;
    curr = new node;
    curr->data=arr[t];
    curr->lchild=NULL;
    curr->rchild=NULL;
    creatHeap(curr->lchild,2*t);
    creatHeap(curr->rchild,2*t+1);
}
void isHeap(node *curr)
{
    if(curr==NULL)
        return;
    if(curr->lchild&&flag&&curr->lchild->data > curr->data
       ||curr->rchild&&flag&&curr->rchild->data > curr->data )
            heap=false;
    if(curr->lchild && !flag&&curr->lchild->data < curr->data
       ||curr->rchild&& !flag&&curr->rchild->data < curr->data)
            heap=false;
    isHeap(curr->lchild);
    isHeap(curr->rchild);
}
void postorder(node* curr)
{
    if(curr!=NULL)
    {
        postorder(curr->lchild);
        postorder(curr->rchild);
        if(first)
        {
            printf("%d",curr->data);
            first=false;
        }
        else
            printf(" %d",curr->data);
    }
}
int main()
{
    cin>>M>>N;
    int i;
    while(M--)
    {
        for(i=1;i<=N;i++)
            scanf("%d",&arr[i]);
        flag=false;
        heap=true;
        first=true;
        for(i=2;i<=N;i++)
            if(arr[i]!=arr[1])
            {
                flag=!(arr[i]>arr[1]);
                break;
            }
        node *root=NULL;
        creatHeap(root,1);
        isHeap(root);
        if(heap)
        {
            if(flag)
                printf("Max Heap\n");
            else
                printf("Min Heap\n");
        }
        else
            printf("Not Heap\n");
        postorder(root);
        printf("\n");
//flag爲true表示可能時大根堆,false可能時小根堆
    }
    return 0;
}

發佈了177 篇原創文章 · 獲贊 18 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章