HDUOJ-1052(poj-2287)(田忌賽馬)(貪心)

HDUOJ-1052(poj-2287)(田忌賽馬)(貪心)

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24864    Accepted Submission(s): 7244


Problem Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 

Sample Input
3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0
 

Sample Output
200 0 0
 注:思路,解釋,參考:http://www.cnblogs.com/anderson0/archive/2011/05/07/2039971.html,這篇題解比較詳細。
特別注意當田忌的最快馬和齊王的最快馬速度相等時,若田忌的最慢馬比齊王的最慢馬快時,應用田忌的最慢馬抵消齊王的最慢馬。
如:田忌:4   3
       齊王:4   1
若:4<--->4,平局,3<-->1,田忌贏,最終田忌贏200金幣。
起初自己沒有考慮到這種情況,每當田忌的最快馬比齊王的最快馬慢時,就用田忌的最慢馬抵消齊王的最快馬。
就是這種結果:
3<-->4,田忌輸200金幣,4<-->1,田忌贏200金幣,最終田忌贏得的金幣數爲0。
起初自己一直沒有找到錯誤原因,直到看到別人的這個測試數據,才發現錯在哪了。
比較好的測試數據(之前一直沒找到,看了別人的題解才發現了這個測試數據,從而找到自己苦苦尋覓許久卻沒有找到的錯誤之處。雖然自己錯了,但是找到錯誤之處,好激動)
2
4 3
4 1
My  solution:
/*2016.3.27*/
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int x[1010],y[1010];
int main()
{
	int i,j,n,m,h,sum;
	int x_min,x_max,y_min,y_max;
	while(scanf("%d",&n)==1&&n)
	{
		sum=0;
		for(i=1;i<=n;i++)
		   scanf("%d",&x[i]);
		for(j=1;j<=n;j++)
		   scanf("%d",&y[j]);
		sort(x+1,x+n+1);
		sort(y+1,y+n+1);
		x_min=y_min=1;
		x_max=y_max=n;
		while(x_min<=x_max&&y_min<=y_max)
		{
			if(x[x_max]>y[y_max])//1.田忌最快馬比齊王最快馬快,兩者抵消 
			{
				sum+=200;
				x_max--;
				y_max--;
			}
			else if(x[x_max]==y[y_max])//2.田忌最快馬和齊王最快馬一樣快
			{
				if(x[x_min]>y[y_min])//2.(1) 田忌最慢馬比齊王最慢馬快,兩者抵消 
				{
					x_min++;
					y_min++;
					sum+=200;
				}
				else 
				{
					if(x[x_min]<y[y_max])//2.(2)當 x[x_min]==y[y_max],就是平局,不輸贏金幣(田忌最慢馬和齊王最快馬一樣快) 
					sum-=200;            // 可能是x_min==x_max,說明此時是最後一匹馬的比賽,且爲平局.也可能不是最後一局,但田忌剩下的馬速度都相等 
					y_max--;
					x_min++;
				}	
			}
		    else //x[x_max]<y[y_max]。3.田忌的最快馬比齊王最快馬慢 
		    //if(x[x_min]<y[y_max])因:田忌的最快馬比齊王最快馬慢 ,所以一定滿足 x[x_min]<y[y_max],絕不可能滿足:x[x_min]==y[y_max]
			{
				sum-=200;
				y_max--;
				x_min++; 
			}
		}
		printf("%d\n",sum);
	}
	return 0;
 } 


發佈了144 篇原創文章 · 獲贊 10 · 訪問量 8萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章