廣搜:Catch That Cow

Catch That Cow

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 57   Accepted Submission(s) : 35
Problem Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
5 17
 

Sample Output
4
 

Source
PKU

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<queue>

using namespace std;

bool used[100005];          //true 表示這點沒有到過
long n,k;
struct point
{
    long x,step;            //x 存位置,step存到這步的步數
};
long bfs(long n,long k)
{
    queue<point>que;
    point tp,ans;
    long tn;
    ans.x=n;
    ans.step=0;
    used[n]=false;
    que.push(ans);
    while(1)
    {
        tp=que.front();
        tn=tp.x+1;              //往前走
        que.pop();
        
        if(tn>=0&&tn<=100000)
        {
            if(used[tn])
            {
                 used[tn]=false;
                 ans.x=tn;
                 ans.step=tp.step+1;
                 que.push(ans);
                 if(ans.x==k)
                     return ans.step;
            }
        }
        tn=tp.x-1;                            //往後走
        if(tn>=0&&tn<=100000)
        {
            if(used[tn])
            {
                used[tn]=false;
                ans.x=tn;
                ans.step=tp.step+1;
                que.push(ans);
                if(ans.x==k)
                    return ans.step;
            }
        }
        tn=2*tp.x;                 //兩倍距離
        if(tn>=0&&tn<=100000)
        {
        if(used[tn])
            {
                used[tn]=false;
                ans.x=tn;
                ans.step=tp.step+1;
                que.push(ans);
                if(ans.x==k)
                    return ans.step;
            }
        }
    }
}
int main()
{
    long sum;
    cin>>n>>k;
        if(n>k||n==k)
        cout<<n-k;
        else
        {
            memset(used,true,sizeof(used));
                sum=bfs(n,k);
            cout<<sum;
        }
    
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章