深搜:Nightmare

Nightmare

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 42   Accepted Submission(s) : 18
Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
 

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
 

Sample Input
3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
 

Sample Output
4 -1 13
 

Author
Ignatius.L
 

時間爲6,走一步少一個,遇到4可以回到6,注意4用完了就變成1;

另外注意可以走走過的路。

深度遍歷。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<string>

using namespace std;

int map[11][11];
int used[11][11];
struct point{
    int x,y;
	int step;
	int time;
};
long bfs(int begx,int begy,int endx,int endy){
	memset(used,0,sizeof(used));
    int i,j,tmp;
	queue<point>que;
	point tp,ans;
	int flag;
	long xn,yn,tn;
	ans.x=begx;
	ans.y=begy;
	ans.step=0;
    ans.time=6;
	used[begx][begy]++;
	que.push(ans);
    int dir[4][2]={{0,-1},{0,1},{-1,0},{1,0}};
	//printf("sdfsd");
	while(1){
		flag=1;
		tp=que.front();
		//tmp=tp.step;
		que.pop();
		//printf("ddd");
		for(i=0;i<4;i++){
		    if(tp.time==1)
				break;
			tn=tp.time;
			xn=tp.x+dir[i][0];
		    yn=tp.y+dir[i][1];
			//printf("ddd");
		    if(map[xn][yn]&&used[xn][yn]!=100){
				//flag=0;
				used[xn][yn]++;
                ans.time=tn-1;
				if(map[xn][yn]==4){
					map[xn][yn]=1;
				    ans.time=6;
				}
				ans.x=xn;
				ans.y=yn;
				//printf("\n%d %d\n",xn,yn);
				ans.step=tp.step+1;
				que.push(ans);
				if(ans.x==endx&&ans.y==endy)
					return ans.step;
			}
		}
		if(!(que.size()))
			break;
	}
	return -1;
}
int main(){
	int m,n,t,x,y,X,Y,i,j,sum;
	cin>>t;
	while(t--){
	cin>>m>>n;
	for(i=1;i<=m;i++)
		for(j=1;j<=n;j++){
			scanf("%d",&map[i][j]);
			if(map[i][j]==2){
				x=i;
				y=j;
			}
			else if(map[i][j]==3){
				X=i;
				Y=j;
			}
		}
	sum=bfs(x,y,X,Y);
	cout<<sum<<endl;
	//memset(tmp,0,sizeof(tmp));
	//memset(used,true,sizeof(used));
	}
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章