Zoj 3870 Team Formation(異或運算)

Team Formation

Time Limit: 3 Seconds      Memory Limit: 131072 KB

For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from N students of his university.

Edward knows the skill level of each student. He has found that if two students with skill level A and B form a team, the skill level of the team will be A ⊕ B, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e. A ⊕ B > max{AB}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains N positive integers separated by spaces. The ith integer denotes the skill level of ith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input

2
3
1 2 3
5
1 2 3 4 5

Sample Output

1
6

題意:給出n個數,每次選2個數,問一共有多少種選法使得選出的這兩個數異或後的值,這兩個數中的最大值還要大。

分析:異或運算:1^1=0, 1^0=1, 0^1=1, 0^0=0。
對於一個數,如果我們把x的二進制表示中最高位的0變成1,0前面的都不變,那麼得到的這個新值肯定比x大。即:如果x的第i位爲1(i爲x的最高位的1所在位置),y的第i位爲0(i不是y的最高位所在位置),那麼z=x^y之後,z > max(x, y)。
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int MaxN = 1e5 + 10;
int a[MaxN], bit[50]; // bit[i]表示有多少個數的最高位的1在第i位上

void solve(int x) {
    int l = 31;
    while(l >= 0) {
        if(x & (1<<l)) {
            bit[l]++;
            return ;
        }
        l--;
    }
    return ;
}

int main() {
    int T, n;
    scanf("%d", &T);
    while(T--) {
        scanf("%d", &n);
        memset(bit, 0, sizeof(bit));
        for(int i = 0; i < n; i++) {
            scanf("%d", &a[i]);
            solve(a[i]);
        }
        int ans = 0;
        for(int i = 0; i < n; i++) {
            int l = 31;
            while(l >= 0) {
                if(a[i] & (1<<l)) break;
                l--;
            }
            while(l >= 0) {
                if(!(a[i] & (1<<l))) ans += bit[l];
                l--;
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章