SCU - 4438(字符串hash)

Censor
frog is now a editor to censor so-called sensitive words (敏感詞).

She has a long text p. Her job is relatively simple – just to find the first occurence of sensitive word w and remove it.

frog repeats over and over again. Help her do the tedious work.

Input
The input consists of multiple tests. For each test:

The first line contains 1 string w. The second line contains 1 string p.

(1≤length of w,p≤5⋅106, w,p consists of only lowercase letter)

Output
For each test, write 1 string which denotes the censored text.

Sample Input

abc
aaabcbc
b
bbb
abc
ab

Sample Output

a
ab

題目大意:給出兩個字符串,然後在第二個字符串中刪去第一個字符串(ps:不是子序列,是如果存在這個字符串就刪去,然後剩下的能夠構成這個字符串就再刪去。)。
解題思路:我們模擬刪去的過程,如果後面的字符串和第一個字符串相同,那麼我們就刪去,然後再判斷,這裏我們判斷是否相同使用字符串hash來做,如果刪去,就表示我們的這一位是在前x位(x是第一個字符串的長度)。

代碼:

#pragma GCC optimize(2)
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string>
#include <vector>
#include <set>
#include <map>
#include <stack>
#include <bitset>
#include <queue>
//#include <random>
#include <time.h>
using namespace std;
#define int long long
#define ull unsigned long long
#define ls root<<1
#define rs root<<1|1
const int maxn = 5e6 + 7;
//std::mt19937 rnd(time(NULL));
stack<char> st;
string a, b;
ull det[maxn], hash1[maxn], s;
signed main()
{
    det[0] = 1;
    for (int i = 1; i < maxn;i++)
        det[i] = det[i - 1] * 131;
    
    while (cin >> a >> b){
        while(!st.empty())
            st.pop();
        s = 0;
        for (int i = 0; a[i] != '\0';i++){
            s = s * 131 + a[i];
        }
        int cnt = 0;
        for (int i = 0; b[i] != '\0';i++){
            st.push(b[i]);
            if(st.size()==1){
                hash1[++cnt] = b[i];
            }
            else{
                cnt++;
                hash1[cnt] = hash1[cnt - 1] * 131 + b[i];
            }
            if(st.size()>=a.size() && (hash1[cnt]-hash1[cnt-a.size()]*det[a.size()])==s){
                for (int j = 1; j <= a.size();j++){
                    cnt--;
                    st.pop();
                }
            }
        }
        string ans;
        while(!st.empty()){
            ans += st.top();
            st.pop();
        }
        reverse(ans.begin(), ans.end());
        cout << ans << endl;
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章