HDUOJ Let the Balloon Rise



 

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 125039    Accepted Submission(s): 49360


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
5 green red blue red red 3 pink orange pink 0
 

Sample Output
red pink
 

Author
WU, Jiazhi
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1002 1001 1008 1005 1003 
 

#include <iostream>
#include <map>
#include <string>
using namespace std;
map<string, int> mp;
int main()
{
    int n;
    while (cin>>n, n!=0)
    {
        string s,p;
        int mx=0;
        for (int i=0;i<n;i++)
        {
            cin>>s;
            if (mp.find(s)==mp.end())
            {
                mp[s]=1;
                if (1>mx)
                {
                    mx=1;
                    p=s;
                }
            }
            else
            {
                mp[s]++;
                if (mp[s]>mx)
                {
                    mx=mp[s];
                    p=s;
                }
            }
        }
        cout << p << endl;
    }
}

 



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章