FatMouse' Trade

FatMouse' Trade

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 16   Accepted Submission(s) : 9

Font: Times New Roman | Verdana | Georgia

Font Size:

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500

Author

CHEN, Yue

Source

ZJCPC2004
#include<stdio.h>
struct node
{
    int a;
    int b;
    double c;
};
struct node st[1000],t;
int main()
{
    int n,m,i,j,s1,flag;
    double sum;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==-1&&m==-1) break;
        for(i=0;i<=m-1;i++)
        {
            scanf("%d%d",&st[i].a,&st[i].b);
            st[i].c=(double)st[i].a/st[i].b;
        }
        for(i=0;i<=m-2;i++)
           for(j=i+1;j<=m-1;j++)
           {
               if(st[i].c<st[j].c)
               {
                   t=st[i];
                   st[i]=st[j];
                   st[j]=t;
               }
           }
           s1=0;
               sum=0;
               flag=1;
           for(i=0;i<=m-1&&flag==1;i++)
           {
              s1+=st[i].b;
              if(s1<=n)
              {
                  sum+=(double)st[i].a;
              }
              else
              {
                  s1=n-(s1-st[i].b);
                  sum+=(double)s1*st[i].c;
                  flag=0;
              }
           }
           printf("%.3lf\n",sum);

    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章