POJ - 2566 Bound Found(前綴+尺取)

題目鏈接:http://poj.org/problem?id=2566點擊打開鏈接


Bound Found
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 5089   Accepted: 1622   Special Judge

Description

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We'll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t. 

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.

Input

The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.

Output

For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.

Sample Input

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0

Sample Output

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15


記錄前綴和後排序 使數組具有單調性

然後進行尺取

#include <vector>
#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <limits.h>
using namespace std;
struct xjy
{
    int sum;
    int num;
    bool operator < (const xjy &r)const
    {
        return sum<r.sum;
    }
};
int s[1111111];
vector<xjy > ss;
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)&&n&&m)
    {
        s[0]=0;
        ss.clear();
        for(int i=1;i<=n;i++)
        {
            int mid;
            scanf("%d",&s[i]);
        }
        int mid=0;
        xjy midmid;
        midmid.num=0;
        midmid.sum=0;
        ss.push_back(midmid);
        for(int i=1;i<=n;i++)
        {
            mid+=s[i];
            midmid.sum=mid;
            midmid.num=i;
            ss.push_back(midmid);
        }
        sort(ss.begin(),ss.end());
        while(m--)
        {
            scanf("%d",&mid);
            int l=0,r=1;
            int cnt=INT_MAX;
            int cntl,cntr;
            int ans=0;
            while(r<=n)
            {
                if(abs((ss[r].sum-ss[l].sum)-mid)<cnt)
                {
                    ans=ss[r].sum-ss[l].sum;
                    cnt=abs(ss[r].sum-ss[l].sum-mid);
                    cntl=ss[l].num;
                    cntr=ss[r].num;
                }
                if(ss[r].sum-ss[l].sum<mid)
                    r++;
                else
                    l++;
                if(l==r)
                    r++;
            }
            cout << ans << " " << min(cntr,cntl)+1 << " " << max(cntr,cntl) <<endl;
        }
    }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章