HDU 1532 Drainage Ditches

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4748 Accepted Submission(s): 2210


Problem Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input
5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10

Sample Output
50

Source

Recommend
lwg

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <vector>
#include <string>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <list>

#define INT_INF 0x3fffffff
#define LL_INF 0x3fffffffffffffff
#define EPS 1e-12
#define MOD 1000000007
#define PI 3.141592653579798
#define N 2222
#define E 500000

using namespace std;

typedef long long LL;
typedef unsigned long long ULL;
typedef double DB;

struct Edge
{
    int st,en,cap,flow,op,next;
} edge[E];
int head[N] , tot , now[N];
int source,sink,tot_num;
int pre[N] , dis[N] , gap[N];

void add_edge(int st,int en,int cap)
{
    edge[tot].st=st;
    edge[tot].en=en;
    edge[tot].cap=cap;
    edge[tot].flow=0;
    edge[tot].op=tot+1;
    edge[tot].next=head[st];
    head[st]=tot++;

    edge[tot].st=en;
    edge[tot].en=st;
    edge[tot].cap=0;
    edge[tot].flow=0;
    edge[tot].op=tot-1;
    edge[tot].next=head[en];
    head[en]=tot++;
}

vector<int> augment()
{
    int flow=INT_INF,point;
    for(int i=source;i!=sink;i=edge[now[i]].en)
        if(flow>edge[now[i]].cap)
        {
            flow=edge[now[i]].cap;
            point=i;
        }
    for(int i=source;i!=sink;i=edge[now[i]].en)
    {
        edge[now[i]].cap-=flow;
        edge[now[i]].flow+=flow;
        edge[edge[now[i]].op].cap+=flow;
        edge[edge[now[i]].op].flow-=flow;
    }
    vector<int> ans;
    ans.push_back(point);
    ans.push_back(flow);
    return ans;
}

int sap()
{
    memset(dis,0,sizeof(dis));
    memset(gap,0,sizeof(gap));
    memset(pre,-1,sizeof(pre));
    for(int i=0;i<=tot_num;i++)
        now[i]=head[i];
    gap[0]=tot_num;
    int point=source,flow=0;
    while(1)
    {
        if(point==sink)
        {
            vector<int> temp=augment();
            flow+=temp[1];
            point=temp[0];
        }
        int now_edge=-1;
        for(int i=now[point];i!=-1;i=edge[i].next)
            if(edge[i].cap>0 && dis[point]==dis[edge[i].en]+1)
            {
                now_edge=i;
                break;
            }
        if(now_edge==-1)
        {
            if(--gap[dis[point]]==0) break;

            int Min=tot_num;
            for(int i=head[point];i!=-1;i=edge[i].next)
                if(edge[i].cap>0 && Min>dis[edge[i].en])
                {
                    Min=dis[edge[i].en];
                    now[point]=i;
                }
            gap[dis[point]=Min+1]++;
            if(point!=source) point=pre[point];
            continue;
        }
        now[point]=now_edge;
        pre[edge[now_edge].en]=point;
        point=edge[now_edge].en;
    }
    return flow;
}

void build(int n,int m)
{
    memset(head,-1,sizeof(head));
    tot=0;
    source=1; sink=n; tot_num=n;
    int s,t,val;
    for(int i=1;i<=m;i++)
    {
        scanf("%d%d%d",&s,&t,&val);
        add_edge(s,t,val);
    }
}

int main()
{
    int n,m;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        build(n,m);
        int ans=sap();
        printf("%d\n",ans);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章