POJ 1064: Cable master

Cable master

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 83304   Accepted: 16926

Description

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

Sample Input

4 11
8.02
7.43
4.57
5.39

Sample Output

2.00

Source

Northeastern Europe 2001

 

需要使用二分來解題:

#include <stdio.h>
#include <math.h>

#define MAX_L	100000

double delta = 0.001;//10e-6;

int getCount(double *array, double len, double maxLen)
{
	int i;
	int count = 0;
	for(i = 0; i < len; ++i)
	{
		count += array[i]/maxLen;
	}

	return count;
}

double solve(double *L, int N, int K)
{

	double lo = 0, hi = MAX_L;

	while( hi > delta + lo)
	{
		double mid = ( hi + lo)/2;
		
		int count = getCount(L, N, mid);

		if(count < K)
		{
			hi = mid;
		}
		else
		{
			lo = mid;
		}
	} 

	return hi;
}

#define MAX_N	10000

int main(void)
{
	double L[MAX_N];
	int N, K;
	scanf("%d %d", &N, &K);
	int i;
	for(i = 0; i < N; ++i)
	{
		scanf("%lf", &L[i]);	
	}
	double ret = solve(L, N, K);
//	printf("%.2f\n", floor(ret*100)/100);
	printf("%.2f\n", ((int)(ret*100))/100.0);
	return 0;
}

需要注意的點:

1. printf裏面,不要用"%.2lf"來打印浮點數,否則提交的時候會顯示結果不對。。

2. 題目保留兩位小數,不能簡單的用  printf("%.2f\n", ret); 因爲這樣默認會有四捨五入,和題目要求 不一致。

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章