HDU1013Digital Roots

題目:

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output

For each integer in the input, output its digital root on a separate line of the output.

Sample Input

24
39
0

Sample Output

6
3

思路:

是一個水題,只有一個要注意的地方。

  1. 因爲輸入的位數可能非常長,所以C++裏規定的所有整型都可能不夠長。
  2. 因此採用一個String對象來儲存最原始的輸入。
  3. 由於一個幾萬位的數字各位的數字加起來其和業不過即使幾十萬
  4. 因此後面的結果可以直接用int型儲存。
  5. 注意本題看上去是一個數字問題,其實,主要考察的是字符串的內容

附上代碼:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
int sumDig(string n)
{
    int sum,i;
    sum=0;
    for(i=0;i<n.size();i++){//n.size()求string的長度
        sum=sum+n[i]-48;
    }
    return sum;
}//第一次計算各位和用
int sumDig2(int n)
{
    int sum=0;
    while(n!=0){
        sum=sum+n%10;
        n=n/10;
    }
    return sum;
}//除第一次外計算各位和用
int main()
{
    string n;
    int sum;
    while(cin>>n&&!(n=="0")){
        sum=sumDig(n);
        while(sum>=10){
            sum=sumDig2(sum);
        }
        cout<<sum<<endl;
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章