hdu 5339 Untitled (dfs)

Untitled

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1294    Accepted Submission(s): 759


Problem Description
There is an integer a and n integers b1,,bn. After selecting some numbers from b1,,bn in any order, say c1,,cr, we want to make sure that a mod c1 mod c2 mod mod cr=0 (i.e., a will become the remainder divided by ci each time, and at the end, we want a to become 0). Please determine the minimum value of r. If the goal cannot be achieved, print 1 instead.
 

Input
The first line contains one integer T5, which represents the number of testcases. 

For each testcase, there are two lines:

1. The first line contains two integers n and a (1n20,1a106).

2. The second line contains n integers b1,,bn (1in,1bi106).
 

Output
Print T answers in T lines.
 

Sample Input
2 2 9 2 7 2 9 6 7
 

Sample Output
2

-1

solution:

我們知道一個大數模小數大數會變小,而小數模大數不變,因此我們把b[i]從大到小排序,然後dfs即可

#include<cstdio>
#include<algorithm>
using namespace std;
int b[30],n;
bool cmp(int a, int b)
{
    return a > b;
}
int dfs(int cnt, int pos, int remain)
{
    if (remain == 0)return cnt;
    if (pos >= n)return n + 1;
    int x = dfs(cnt, pos + 1, remain);
    int y = dfs(cnt + 1, pos + 1, remain%b[pos]);
    return min(x, y);
}
int main()
{
    int t,a;
    scanf("%d", &t);
    while (t--)
    {
        scanf("%d%d", &n, &a);
        for (int i = 0; i < n; i++)
            scanf("%d", &b[i]);
        sort(b, b + n,cmp);
        int x = dfs(0, 0, a);
        if (x == n + 1)printf("-1\n");
        else printf("%d\n", x);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章