hdu 5437 Alisha’s Party(優先隊列)

Alisha’s Party

Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 4167    Accepted Submission(s): 1069


Problem Description
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the nth person to enter her castle is.
 

Input
The first line of the input gives the number of test cases, T , where 1T15.

In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1k150,000. The door would open m times before all Alisha’s friends arrive where 0mk. Alisha will have q queries where 1q100.

The ith of the following k lines gives a string Bi, which consists of no more than 200 English characters, and an integer vi1vi108, separated by a blank. Bi is the name of the ith person coming to Alisha’s party and Bi brings a gift of value vi.

Each of the following m lines contains two integers t(1tk) and p(0pk) separated by a blank. The door will open right after the tth person arrives, and Alisha will let p friends enter her castle.

The last line of each test case will contain q numbers n1,...,nq separated by a space, which means Alisha wants to know who are the n1th,...,nqthfriends to enter her castle.

Note: there will be at most two test cases containing n>10000.
 

Output
For each test case, output the corresponding name of Alisha’s query, separated by a space.
 

Sample Input
1 5 2 3 Sorey 3 Rose 3 Maltran 3 Lailah 5 Mikleo 6 1 1 4 2 1 2 3
 

Sample Output
Sorey Lailah Rose

solution:

此題用優先隊列解題,注意題中有幾個坑點,當m次開門後要讓剩下所有的人都進來,還有給的開門順序不一定是有序的,要自己排序,若剩下的不夠p人,就讓剩下的都進來,總之小心一點就好,詳細看代碼~

#include<cstdio>
#include<algorithm>
#include<queue>
#include<cstring>
using namespace std;
struct node{
	int id, val;
	char s[210];
	bool operator < (const node &x)const
	{
		if (x.val == val)return x.id < id;
		return x.val > val;
	}
}a[150500];
int num[150500],time[150500];
int main()
{
	int T,k,m,q,t,p;
	scanf("%d", &T);
	while (T--)
	{
		memset(time, 0, sizeof(time));
		scanf("%d%d%d", &k, &m, &q);
		for (int i = 1; i <= k; i++)
		{
			a[i].id = i;
			scanf("%s%d", a[i].s, &a[i].val);
		}
		int len = 1;
		priority_queue<node>que;
		for (int i = 0; i < m; i++)
		{
			scanf("%d%d", &t, &p);
			time[t] = p;
		}
		for (int i = 1; i <= k; i++)
		{
			que.push(a[i]); 
			while (!que.empty() && time[i])
			{
				num[len++] = que.top().id;
				que.pop();
				time[i]--;
			}
		}
		while (!que.empty())
		{
			num[len++] = que.top().id;
			que.pop();
		}
		for (int i = 1; i <=q; i++)
		{
			scanf("%d", &p); 
			printf("%s%c", a[num[p]].s, i == q ? '\n' : ' ');
		}
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章