線性結構4 Pop Sequence

線性結構4 Pop Sequence

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO

#include <stdio.h>
#include <stdlib.h>
#define Maximum 1001

int m,n,k;

typedef struct
{
    int capacity;
    int data[Maximum];
    int top;
}stack;

void InitStack(stack *s,int m);
int StackEmpty(stack s);
int GetTop(stack s,int *e);
int Push(stack *s,int e);
int Pop(stack *s,int *e);
int StackLength(stack s);
void clear(stack *s);
int Ispossible(int *a,int m,int n);

int main()
{
    scanf("%d %d %d",&m,&n,&k);
    int i,j;
    int a[Maximum];
    for (i=0;i<k;i++)
    {
        for (j=0;j<n;j++) scanf("%d",&a[j]);
        if (Ispossible(a,m,n)) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

void InitStack(stack *s,int m)
{
    s->top=0;
    s->capacity=m;
}

int StackEmpty(stack s)
{
    if(s.top==0)return 1;
    else return 0;
}

int GetTop(stack s,int *e)
{
    if(s.top<=0)return 0;
    else
    {
        *e=s.data[s.top-1];
        return 1;
    }
}

int Push(stack *s,int e)
{
    if(s->top>=s->capacity) return 0;
    else
    {
        s->data[s->top]=e;
        s->top++;
        return 1;
    }
}

int Pop(stack *s,int *e)
{
    if(s->top==0) return 0;
    else
    {
        s->top--;
        *e=s->data[s->top];
        return 1;
    }
}

int StackLength(stack s)
{
    return s.top;
}

void clear(stack *s)
{
    s->top=0;
}

int Ispossible(int *a,int m,int n)
{
    int i,head=0,e,status;
    stack s;
    InitStack(&s,m);
    for(i=1;i<=n;i++)
    {
        e=0;
        if(!Push(&s,i)) return 0;
        status=GetTop(s,&e);
        while(e==a[head])
        {
            status=Pop(&s,&e);
            head++;
            status=GetTop(s,&e);
        }
    }
    if(head==n) return 1;
    else return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章