POJ 1844 Sum

http://poj.org/problem?id=1844

Sum
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 9716   Accepted: 6350

Description

Consider the natural numbers from 1 to N. By associating to each number a sign (+ or -) and calculating the value of this expression we obtain a sum S. The problem is to determine for a given sum S the minimum number N for which we can obtain S by associating signs for all numbers between 1 to N. 

For a given S, find out the minimum value N in order to obtain S according to the conditions of the problem. 

Input

The only line contains in the first line a positive integer S (0< S <= 100000) which represents the sum to be obtained.

Output

The output will contain the minimum number N for which the sum S can be obtained.

Sample Input

12

Sample Output

7

Hint

The sum 12 can be obtained from at least 7 terms in the following way: 12 = -1+2+3+4+5+6-7.

Source


#include"stdio.h"
#include"math.h"
int main()
{
	int S,N;
	while(scanf("%d",&S)!=EOF)
	{
		N=(int)sqrt(2.0*S);
		if(N*(1+N)<2*S)
			N++;
		if( (S-(N+1)*N/2) %2 == 0)
			printf("%d\n",N);
		else
		{
			if(N%2)
				printf("%d\n",N+2);
			else
				printf("%d\n",N+1);
		}
	}
	return 0;
}

1844 Accepted 176K 0MS C++ 305B 2013-07-14 13:38:41

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章