POJ 2309 BST

題目鏈接:
http://poj.org/problem?id=2309

難度級別: 2

BST

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7685   Accepted: 4654

Description
Consider an infinite full binary search tree (see the figure below), the numbers in the nodes are 1, 2, 3, .... In a subtree whose root node is X, we can get the minimum number in this subtree by repeating going down the left node until the last level, and we can also find the maximum number by going down the right node. Now you are given some queries as "What are the minimum and maximum numbers in the subtree whose root node is X?" Please try to find answers for there queries. 

Input
In the input, the first line contains an integer N, which represents the number of queries. In the next N lines, each contains a number representing a subtree with root number X (1 <= X <= 231 - 1).
Output
There are N lines in total, the i-th of which contains the answer for the i-th query.
Sample Input
2
8
10
Sample Output
1 15
9 11
Source
POJ Monthly,Minkerui




#include"stdio.h"
int main()
{
	int n,t,T,cnt;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		t=n;
		cnt=0;
		while(1)
		{
			if(t&1)
				break;
			cnt++;
			t >>= 1;
		}
		t=(1<<cnt) - 1;
		printf("%d %d\n",n-t,n+t);

	}
	return 0;
}

yinjili 2309 Accepted 144K 16MS C++ 261B 2013-08-07 12:01:51

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章