HDU1051--Wooden Sticks

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11070    Accepted Submission(s): 4553


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
2 1 3
 
解析:簡單的貪心問題,但是有點非常容易錯誤,每個stick只能減免一個的stick的執行時間,所以每次的數據需要更新,方法直接排序,可以按照長度或者重量排序都可以,對每個stick進行標記看是否執行過,然後從頭開始遍歷,對於每個stick看能減肥幾個,沒減免一個就需要更新其比較的長度或者重量,如果還是不清楚的話,可以看我的代碼哈!
貼一下自己的代碼哈!
#include<iostream>
#include <algorithm>
using std::endl;
using std::cin;
using std::cout;
using std::sort;
const int MAXN = 5000 + 200;
struct stick{
	int length;
	int weight;
	//標記是否訪問過
	int tag;
}sticks[MAXN];
//排序函數
bool cmp(stick a , stick b)
{
	if(a.length > b.length)
		return true;
	if(a.length == b.length)
		return a.weight > b.weight;
	return false;
}
int main()
{
#ifdef LOCAL
	freopen("input.txt" , "r" , stdin);
#endif
	int T;
	cin >> T;
	while(T--)
	{
		int n;
		cin >> n;
		for(int i=0; i<n; ++i)
		{
			cin >> sticks[i].length >> sticks[i].weight;
			sticks[i].tag = 0;
		}
		sort(sticks , sticks+n , cmp);
		int time = 0 , weight;
		for(int i=0; i<n; ++i)
		{
			//對每個未訪問過的stick進行遍歷
			if(!sticks[i].tag)
			{
				sticks[i].tag = 1;
				time++;
				weight = sticks[i].weight;
				for(int j=i+1; j<n; ++j)
				{
					if(!sticks[j].tag && weight >= sticks[j].weight)
					{
						//如果符合條件可以減免然後更新下次比較的重量
						weight = sticks[j].weight;
						//更新訪問標記
						sticks[j].tag = 1;
					}
				}
			}
		}
		cout << time << endl;
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章