hdu 5813 Elegant Construction(貪心)

Problem Description
Being an ACMer requires knowledge in many fields, because problems in this contest may use physics, biology, and even musicology as background. And now in this problem, you are being a city architect!
A city with N towns (numbered 1 through N) is under construction. You, the architect, are being responsible for designing how these towns are connected by one-way roads. Each road connects two towns, and passengers can travel through in one direction.

For business purpose, the connectivity between towns has some requirements. You are given N non-negative integers a1 .. aN. For 1 <= i <= N, passenger start from town i, should be able to reach exactly ai towns (directly or indirectly, not include i itself). To prevent confusion on the trip, every road should be different, and cycles (one can travel through several roads and back to the starting point) should not exist.

Your task is constructing such a city. Now it’s your showtime!

Input
The first line is an integer T (T <= 10), indicating the number of test case. Each test case begins with an integer N (1 <= N <= 1000), indicating the number of towns. Then N numbers in a line, the ith number ai (0 <= ai < N) has been described above.

Output
For each test case, output “Case #X: Y” in a line (without quotes), where X is the case number starting from 1, and Y is “Yes” if you can construct successfully or “No” if it’s impossible to reach the requirements.

If Y is “Yes”, output an integer M in a line, indicating the number of roads. Then M lines follow, each line contains two integers u and v (1 <= u, v <= N), separated with one single space, indicating a road direct from town u to town v. If there are multiple possible solutions, print any of them.

Sample Input

3
3
2 1 0
2
1 1
4
3 1 1 0

Sample Output

Case #1: Yes
2
1 2
2 3
Case #2: No
Case #3: Yes
4
1 2
1 3
2 4
3 4

Author
SYSU

Source
2016 Multi-University Training Contest 7

還是剛開始沒有讀懂題意,以爲要找最小路徑數。看到題解的時候,心都碎了。。。

將頂點按能到達的點數從小到大排序,排好序之後每個點只能往前面的點連邊. 因而如果存在一個排在第i位的點,要求到達的點數大於i-1,則不可行;否則就可以按照上述方法構造出圖. 複雜度O(N^2).

上個自己寫的代碼吧。

/*===============================================================
*   Copyright (C) 2016 All rights reserved.
*   
*   文件名稱:1005.cpp
*   創 建 者:gsh
*   創建日期:2016年08月09日
*   描    述:DAG的貪心題
*
*   更新日誌:
*
================================================================*/
#include <bits/stdc++.h>
typedef long long ll;
typedef unsigned long long ull;
using namespace std;
struct p
{
    int id;
    int num;
};
p a[2000];
bool cmp(p x, p y)
{
    return x.num < y.num;
};
int main()
{
    //freopen("1005.in","r",stdin);
    //freopen("1005.out","w",stdout);
    int t, kase = 0;
    scanf("%d", &t);
    while(t--)
    {
        int n;
        scanf("%d", &n);
        for(int i = 1; i <= n; i++)
        {
            int q;
            scanf("%d", &q);
            a[i].id = i;
            a[i].num = q;
        }
        sort(a+1, a+n+1, cmp);
        int flag = 0;
        for(int i = 1; i <= n; i++)
        {
           if(a[i].num > i - 1)
           {
               flag = 1;
               break;
           }
        }
        if(flag)
        {
            printf("Case #%d: No\n", ++kase);
            continue;
        }
        printf("Case #%d: Yes\n", ++kase);
        int ans = 0;
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= a[i].num; j++)
                ans++;
        }
        printf("%d\n",ans);
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= a[i].num; j++)
            {
                 printf("%d %d\n", a[i].id, a[j].id);
            }
        }
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章