hdu1237-簡單計算器

Problem Description

讀入一個只包含 +, -, *, / 的非負整數計算表達式,計算該表達式的值。

Input

測試輸入包含若干測試用例,每個測試用例佔一行,每行不超過200個字符,整數和運算符之間用一個空格分隔。沒有非法表達式。當一行中只有0時輸入結束,相應的結果不要輸出。

Output

對每個測試用例輸出1行,即該表達式的值,精確到小數點後2位。

Sample Input

1 + 2
4 + 2 * 5 - 7 / 11
0

Sample Output

3.00
13.36


#include<stdio.h>
#include<string.h>
#include<iostream>
#include<stack>
#include<ctype.h>
using namespace std;
char str[1000];
int len;
struct ss
{
    int num,k;
} s;
ss get_num(int n)
{
    ss ans;
    int i,sum=0;
    for(i=n; i<len&&isdigit(str[i]); i++)
        sum=sum*10+str[i]-'0';
    ans.k=i;
    ans.num=sum;
    return ans;
}
double f(double c,double b,int oper)
{
    if(oper==1)return c+b;
    if(oper==2)return c-b;
    if(oper==3)return c*b;
    return  c/b;
}
int main()
{
    int i,j,flag,b,ope;
    double a,c,d,ans;
    while(gets(str))
    {
        if(!strcmp(str,"0"))break;
        len=strlen(str);
        stack<double>num;
        stack<int>oper;
        i=0;
        flag=1;
        while(i<len)
        {
            if(flag)
            {
                s=get_num(i);
                a=s.num*1.0;
                num.push(a);
                i=s.k;
                flag=0;
            }
            else
            {
                if(str[i+1]=='+')b=1;
                else if(str[i+1]=='-')b=2;
                else if(str[i+1]=='*')b=3;
                else  b=4;
                while(!oper.empty())
                {
                    ope=oper.top();
                    if(b==1||b==2||(ope>2&&ope+b>=6))
                    {

                        c=num.top();
                        num.pop();
                        d=num.top();
                        num.pop();
                        oper.pop();
                        a=f(d,c,ope);
                        num.push(a);
                    }
                    else break;
                }
                oper.push(b);
                i+=3;
                flag=1;
            }
        }
        while(num.size()>1)
        {
            c=num.top();
            num.pop();
            d=num.top();
            num.pop();
            ope=oper.top();
            oper.pop();
            a=f(d,c,ope);
            num.push(a);
        }
        printf("%.2lf\n",num.top());
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章