HDU 1002 A + B Problem II C++解法

題目

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

代碼

由於A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
所以必須用字符串實現大數加法

大數加法

  1. 判斷是否爲特殊情況

    1.1a,b字符串皆爲空,則輸出0
    1.2a字符串爲空,則輸出b
    1.3b字符串爲空,則輸出a

  2. 翻轉a,b字符串

    因爲大數加法是從低位往高位加,而字符串是從高位往低位寫入的,所以需要對a,b字符串進行翻轉,這裏運用的是reverse函數

    頭文件要加algorithm
    reverse(N.begin(), N.end())

  3. 總是讓a作爲較短的那個字符串,而b作爲目標字符串(每一位的加法只需要循環到lena即可)

    這裏寫了兩個swap函數來交換字符串和表示字符串長度的變量

void swapstring(string &a, string &b)
{
	string t = a;
	a = b;
	b = t;
	return;
}
void swap(int &a, int &b){
	int t = a;
	a = b;
	b = t;
	return;
}
  1. 設置進位標誌flag

  2. a,b都有數的每一位的加法計算
    5.1用isdigit判斷加後的和數是否仍爲0~9的數字
    5.2若當前進位符爲true則+1且flag = false,回溯爲不進位
    5.3若不爲數字,則flag = true進位,並且b[i] -= 10

  3. a被用完了若還有進位則靠這一位進位還要與剩餘的b字符串的高位數進行加法運算
    循環直到進位符爲false,表示不再進位了

    6.1如果長度相等,b字符串最高位添一位1,flag = false
    6.2否則在走到的當前位上+1
    ~6.2.1加後如果不是數字,進位符flag = true,且b[lena] -= 10
    ~6.2.2如果是數字,flag = false

  4. 翻轉目標字符串b,返回b

string SUM(string a, string b){
	if (a == ""&&b == "")
		return "0";
	if (a == "")
		return b;
	if (b == "")
		return a;
	/*特殊情況*/

	int lena = a.length(),lenb=b.length();
	reverse(a.begin(), a.end());
	reverse(b.begin(), b.end());
	bool flag = false;
	if (lena > lenb){
		swap(lena, lenb);
		swapstring(a, b);
	}
	for (int i = 0; i < lena; i++){
		b[i] += a[i] - '0';
		if (flag){
			b[i] += 1;
			flag = false;
		}
		if (!isdigit(b[i])){
			flag = true;
			b[i] -= 10;
		}
	}
	while(flag){//較短的最高位進位不知道要進幾次位
		if (lena == lenb){
			b += '1';
			flag = false;
		}
		else{
			b[lena] += 1;
			if (!isdigit(b[lena])){
				flag = true;
				b[lena] -= 10;
			}
			else
				flag = false;
		}	
		lena++;
	}
	reverse(b.begin(), b.end());
	return b;
}

AC代碼

#include<stdio.h>
#include<iostream>
#include<string>
#include<algorithm>
#include<stdlib.h>
using namespace std;
void swapstring(string &a, string &b)
{
	string t = a;
	a = b;
	b = t;
	return;
}
void swap(int &a, int &b){
	int t = a;
	a = b;
	b = t;
	return;
}
string SUM(string a, string b){
	if (a == ""&&b == "")
		return "0";
	if (a == "")
		return b;
	if (b == "")
		return a;
	/*特殊情況*/

	int lena = a.length(),lenb=b.length();
	reverse(a.begin(), a.end());
	reverse(b.begin(), b.end());
	bool flag = false;
	if (lena > lenb){
		swap(lena, lenb);
		swapstring(a, b);
	}
	for (int i = 0; i < lena; i++){
		b[i] += a[i] - '0';
		if (flag){
			b[i] += 1;
			flag = false;
		}
		if (!isdigit(b[i])){
			flag = true;
			b[i] -= 10;
		}
	}
	while(flag){//較短的最高位進位不知道要進幾次位
		if (lena == lenb){
			b += '1';
			flag = false;
		}
		else{
			b[lena] += 1;
			if (!isdigit(b[lena])){
				flag = true;
				b[lena] -= 10;
			}
			else
				flag = false;
		}	
		lena++;
	}
	reverse(b.begin(), b.end());
	return b;
}
int main()
{
	int t;
	scanf("%d", &t);
	for(int i=1;i<=t;i++)
	{
		string a, b;
		cin >> a >> b;
		cout << "Case " << i << ":" << endl;
		cout << a << " + " << b << " = " << SUM(a, b) << endl;
		if (i != t)
			cout << endl;
	}
	system("pause");
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章