HDU杭電1088 Write a simple HTML Browser

http://acm.hdu.edu.cn/showproblem.php?pid=1088


Problem Description
If you ever tried to read a html document on a Macintosh, you know how hard it is if no Netscape is installed. 
Now, who can forget to install a HTML browser? This is very easy because most of the times you don't need one on a MAC because there is a Acrobate Reader which is native to MAC. But if you ever need one, what do you do? 
Your task is to write a small html-browser. It should only display the content of the input-file and knows only the html commands (tags) <br> which is a linebreak and <hr> which is a horizontal ruler. Then you should treat all tabulators, spaces and newlines as one space and display the resulting text with no more than 80 characters on a line.
 

Input
The input consists of a text you should display. This text consists of words and HTML tags separated by one or more spaces, tabulators or newlines. 
A word is a sequence of letters, numbers and punctuation. For example, "abc,123" is one word, but "abc, 123" are two words, namely "abc," and "123". A word is always shorter than 81 characters and does not contain any '<' or '>'. All HTML tags are either <br> or <hr>.
 

Output
You should display the the resulting text using this rules: 
  . If you read a word in the input and the resulting line does not get longer than 80 chars, print it, else print it on a new line. 
  . If you read a <br> in the input, start a new line. 
  . If you read a <hr> in the input, start a new line unless you already are at the beginning of a line, display 80 characters of '-' and start a new line (again). 
The last line is ended by a newline character.
 

Sample Input
Hallo, dies ist eine ziemlich lange Zeile, die in Html aber nicht umgebrochen wird. <br> Zwei <br> <br> produzieren zwei Newlines. Es gibt auch noch das tag <hr> was einen Trenner darstellt. Zwei <hr> <hr> produzieren zwei Horizontal Rulers. Achtung mehrere Leerzeichen irritieren Html genauso wenig wie mehrere Leerzeilen.
 

Sample Output
Hallo, dies ist eine ziemlich lange Zeile, die in Html aber nicht umgebrochen wird. Zwei produzieren zwei Newlines. Es gibt auch noch das tag -------------------------------------------------------------------------------- was einen Trenner darstellt. Zwei -------------------------------------------------------------------------------- -------------------------------------------------------------------------------- produzieren zwei Horizontal Rulers. Achtung mehrere Leerzeichen irritieren Html genauso wenig wie mehrere Leerzeilen.
 


#include <cstdio>
#include <cstring>
char s[81];
int main()
{
	int len, i;
	int cnt = 0;//記錄一行有多少個字符 
	while(~scanf("%s", s))
	{
		if(strcmp(s,"<br>")==0)
		{
			printf("\n");
			cnt = 0;
		}
		else if(strcmp(s,"<hr>")==0)
		{
			if(cnt != 0)
				printf("\n");
			printf("--------------------------------------------------------------------------------");
			printf("\n");
			cnt = 0;
		}
		else
		{
			len = strlen(s);
			if(cnt+len+1 <= 80)//加單詞之前 前面還有個空格,所以要判斷加上這個單詞和這個空格之後 的長度是否大於80 
			{
				if(cnt != 0)
					printf(" ");
				printf("%s", s);
				cnt+=(len+1); 
			}
			else
			{
				printf("\n");
				printf("%s", s);
				cnt = len;
			}
		}
	}
	printf("\n");
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章