数据结构实验之查找三:树的种类统计 SDUT 3375

Problem Description
随着卫星成像技术的应用,自然资源研究机构可以识别每一个棵树的种类。请编写程序帮助研究人员统计每种树的数量,计算每种树占总数的百分比。

Input
输入一组测试数据。数据的第1行给出一个正整数N (n <= 100000),N表示树的数量;随后N行,每行给出卫星观测到的一棵树的种类名称,树的名称是一个不超过20个字符的字符串,字符串由英文字母和空格组成,不区分大小写。

Output
按字典序输出各种树的种类名称和它占的百分比,中间以空格间隔,小数点后保留两位小数。

Sample Input
2
This is an Appletree
this is an appletree

Sample Output
this is an appletree 100.00%

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

struct node
{
	int num;
	char data[35];
	struct node *left, *right;
};

struct node *add(struct node *root, char a[])
{
	if(root==NULL)
	{
		root = (struct node *)malloc(sizeof(struct node));
		root->left = NULL;
		root->right = NULL;
		strcpy(root->data, a);
		root->num = 1;
	}
	else
	{
		if(strcmp(root->data, a) == 0) root->num++;
		else if(strcmp(a, root->data) < 0) root->left = add(root->left, a);
		else root->right = add(root->right, a);
	}
	return root;
}

void PRINT(struct node *root, int n)
{
	if(root==NULL) return;
	else
	{
		PRINT(root->left, n);
		printf("%s %.2lf%%\n", root->data, root->num * 100.0 / n);
		PRINT(root->right, n);
	}
}

int main()
{
	int N, n, i, len;
	struct node *root;
	char a[35];
	scanf("%d", &n);
	root = NULL;
	getchar();
	N = n;
	while(n--)
	{
		gets(a);
		len = strlen(a);
		for(i=0; i<len; i++)
		{
			if(a[i]>='A' && a[i]<='Z') a[i] = a[i] + 'a' - 'A';
		}
		root = add(root, a);
	}
	PRINT(root, N);
	return 0;
} 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章