HDU 4339 Query(線段樹)

Problem Description
You are given two strings s1[0..l1], s2[0..l2] and Q - number of queries.
Your task is to answer next queries:
  1) 1 a i c - you should set i-th character in a-th string to c;
  2) 2 i - you should output the greatest j such that for all k (i<=k and k<i+j) s1[k] equals s2[k].
 

Input
The first line contains T - number of test cases (T<=25).
Next T blocks contain each test.
The first line of test contains s1.
The second line of test contains s2.
The third line of test contains Q.
Next Q lines of test contain each query:
  1) 1 a i c (a is 1 or 2, 0<=i, i<length of a-th string, 'a'<=c, c<='z')
  2) 2 i (0<=i, i<l1, i<l2)
All characters in strings are from 'a'..'z' (lowercase latin letters).
Q <= 100000.
l1, l2 <= 1000000.
 

Output
For each test output "Case t:" in a single line, where t is number of test (numbered from 1 to T).
Then for each query "2 i" output in single line one integer j.
 

Sample Input
1 aaabba aabbaa 7 2 0 2 1 2 2 2 3 1 1 2 b 2 0 2 3
 

Sample Output
Case 1: 2 1 0 1 4 1
 

Source

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>

using namespace std;

const int maxn = 1000100;
int tcase, q;
int cc[maxn<<2][2];
int llen[maxn<<2], rlen[maxn<<2], mlen[maxn<<2]; // 左端點開始的最大的相同長度,右端開始的最大的相同長度,整個區間裏的最大相同長度
char s1[maxn], s2[maxn];

void pushUp(int l, int r, int rt)
{
    int ls = rt << 1;
    int rs = rt << 1 | 1;
    int m = (l + r) >> 1;
    
    llen[rt] = llen[ls];
    rlen[rt] = rlen[rs];
    if (llen[ls] == m - l + 1) {
        llen[rt] += llen[rs]; 
    } 
    if (rlen[rs] == r - m) {
        rlen[rt] += rlen[ls];
    } 
    mlen[rt] = max(rlen[ls] + llen[rs], max(llen[rt], rlen[rt]));
}

void build(int l, int r, int rt)
{
    if (l == r) {
        cc[rt][0] = s1[l];
        cc[rt][1] = s2[l];
        if (cc[rt][0] == cc[rt][1]) {
            rlen[rt] = llen[rt] = mlen[rt] = 1;
        } else {
            rlen[rt] = llen[rt] = mlen[rt] = 0;
        }
        return ;
    } 
    int m = (l + r) >> 1;
    build(l, m, rt << 1);
    build(m + 1, r, rt << 1 | 1);
    pushUp(l, r, rt); 
}

void update(int l, int r, int rt, int p, int id, int c)
{
    if (l == r) {
        cc[rt][id] = c;
        if (cc[rt][id] == cc[rt][!id]) {
            llen[rt] = rlen[rt] = mlen[rt] = 1;
        } else {
            llen[rt] = rlen[rt] = mlen[rt] = 0;
        }
        return ;
    }
    int m = (l + r) >> 1;
    if (p <= m) {
        update(l, m, rt << 1, p, id, c);
    } else {
        update(m + 1, r, rt << 1 | 1, p, id, c);
    }
    pushUp(l, r, rt);
}

int query(int l, int r, int rt, int from)
{
    if (l == r) {
        return mlen[rt];
    }
    int m = (l + r) >> 1;
    if (from <= m) {
        if (rlen[rt<<1] >= m - from + 1) {
            return m - from + 1 + query(m + 1, r, rt << 1 | 1, m + 1);
        } else {
            return query(l, m, rt << 1, from);
        }
    } else {
        return query(m + 1, r, rt << 1 | 1, from);
    }
}

int main()
{
    scanf("%d", &tcase);
    for (int cas = 1; cas <= tcase; ++cas) {
        printf("Case %d:\n", cas);
        scanf("%s", s1);
        scanf("%s", s2);
        int L = min(strlen(s1), strlen(s2));
        build(0, L - 1, 1);
        scanf("%d", &q);
        int op;
        for (int i = 0; i < q; ++i) {
            scanf("%d", &op);
            if (op == 1) {
                int id, p;
                char C;
                scanf("%d %d %c", &id, &p, &C);
                if (p >= L) {
                    continue;
                }
                update(0, L - 1, 1, p, id - 1, C);
            } else {
                int from;
                scanf("%d", &from);
                if (from >= L) {
                    printf("0\n");
                    continue;
                }
                printf("%d\n", query(0, L - 1, 1, from));
            }
        }
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章