PAT甲級真題 1043 Is It a Binary Search Tree (25分) C++實現(二叉搜索樹,遞歸前序轉後序)

題目

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line “YES” if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or “NO” if not. Then if the answer is “YES”, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO

思路

這道題很難理解。

題目意思應該是,給了一個序列,問是否是某個二叉搜索樹的前序或鏡像前序序列?

即可轉化爲,假設它是某個樹的前序序列,其能否構造成二叉搜索樹?

假設它是前序序列,假設它能構成二叉搜索樹,看是否有矛盾。

二叉搜索樹的性質是,左子樹上的所有節點均小於根,右子樹上的所有節點均大於等於根;

前序序列是:根 左子樹 右子樹,即第一個元素是根,接着有連續一段小於根的值構成左子樹,再接着有連續一段大於等於根的值構成右子樹。(鏡像樹同理)

例子

比如測試用例1:

7
8 6 5 7 10 8 11

可成功劃分爲:
在這裏插入圖片描述
接着繼續劃分左右子樹,均符合要求。

再看測試用例3:

7
8 6 8 5 10 9 11

以第一個元素8爲根,小於它的元素時6、5,大於等於它的元素是8、10、9、11,第一次劃分就失敗了。
在這裏插入圖片描述

具體方法

  1. 檢查是否是二叉搜索樹,按照根 左子樹 右子樹的方式迭代劃分序列,若發現不符合要求的,返回false;若一直符合要求,則輸出YES,輸出其後序遍歷數列。
  2. 再檢查是否是鏡像二叉搜索樹,按照根 右子樹 左子樹的方式迭代劃分序列,若發現不符合要求的,直接輸出“No”;若一直符合要求,則輸出YES,輸出其後序遍歷數列。

這裏學習了柳神的方法:

  1. 檢查序列的同時,將後序序列保存到post數組
  2. 若符合要求則遞歸檢查其左子樹和右子樹,最後把根節點加入post數組;若不符合要求直接返回。
  3. 最後檢查post數組元素個數是否等於n,即可知是否符合要求。

代碼

#include <iostream>
#include <vector>
using namespace std;

void getPost(vector<int> pre, int l, int r, vector<int> &post, bool isMirror){
    if (l==r){
        post.push_back(pre[l]);
    }
    else if(l < r){
        int i = l + 1; 
        int j = r;
        if (!isMirror){
            while(i<=r && pre[i]<pre[l]) i++;
            while(j>l && pre[j]>=pre[l]) j--;
        }
        else{
            while(i<=r && pre[i]>=pre[l]) i++;
            while(j>l && pre[j]<pre[l]) j--;
        }
        if (j < i){
            getPost(pre, l+1, j, post, isMirror);
            getPost(pre, i, r, post, isMirror);
            post.push_back(pre[l]);
        }
    }
    return;
}

int main(){
    int n;
    cin >> n;
    vector<int> pre(n);
    for(int i = 0; i < n; i++){
        cin >> pre[i];
    }
    vector<int> post;
    getPost(pre, 0, n-1, post, false);
    if (post.size()<n){  //若假設是二叉搜索樹不成立
        post.clear();
        getPost(pre, 0, n-1, post, true);
    }
    if(post.size()<n){  //若假設是鏡像二叉搜索樹仍不成立
        cout << "NO" << endl;
    }
    else{
        cout << "YES" << endl;
        cout << post[0];
        for (int i=1; i<n; i++){
            cout << " " << post[i];
        }
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章