PAT甲級真題 1047 Student List for Course (25分) C++實現 (需用vector存儲,用set遍歷、插入均O(logn)會超時)

題目

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N(≤40,000)N(\le40,000)N(≤40,000), the total number of students, and K(≤2,500)K(\le2,500)K(≤2,500), the total number of courses. Then N lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number C(≤20)C(\le20)C(≤20) which is the number of courses that this student has registered, and then followed by CCC course numbers. For the sake of simplicity, the courses are numbered from 111 to KKK.

Output Specification:
For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.

Sample Input:
10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:
1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

思路

一開始想到用vector<set<string> >存儲每門課的學生姓名, 姓名在set裏會自動排序。然而最後一個測試點超時。後改用vector<vector<string> >,順利通過。

複雜度分析

課程數是k,學生數是n。

set複雜度

setinsert()複雜度爲logn(n是當前大小),最壞情況下每門課程插入n個學生的名字,用時log1 + log2 + log3 + …… logn = log(n!) = O(nlogn),k門課就是O(knlogn)。

set遍歷操作++--複雜度均爲O(logn),輸出時複雜度又是O(knlogn)。

vector複雜度

若用vector<vector<string> >存儲,插入操作用時kn,遠低於用set的插入;

排序操作用時O(knlogn),輸出時間kn,與set輸出持平。

所以vector+sort()比用set更快。

在這裏插入圖片描述

還要注意必須用scanfprintf輸入輸出才能不超時,用cincout + ios::sync_with_stdio(false); cin.tie(0);依然超時。

代碼

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

int main(){
    //ios::sync_with_stdio(false);
    //cin.tie(0);
    int n, k;
    scanf("%d%d", &n, &k);
    //cin >> n >> k;
    vector<vector<string> > course(k+1);
    for (int i=0; i<n; i++){
        char buf[5];
        int c;
        //cin >> name >> c;
        scanf("%s%d", buf, &c);
        string name(buf);
        for (int j=0; j<c; j++){
            int id;
            scanf("%d", &id);
            //cin >> id;
            course[id].push_back(name);
        }
    }
    for (int i=1; i<k+1; i++){
        sort(course[i].begin(), course[i].end());
        printf("%d %d\n", i, (int)course[i].size());
        //cout << i << " " << course[i].size() << endl;
        for (auto it=course[i].begin(); it!=course[i].end(); ++it){
            printf("%s\n", (*it).c_str());
            //cout << *it << endl;
        }
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章